Skip to Content
author's profile photo Former Member
Former Member

PI 7.4 SPROXY View in ECC

Hi,

We recently upgrade our PI from 7.3 to PI 7.4 SP09.

Surprisingly i found a new look for SPROXY Tcode on ECC side.

PI 7.4 View.

PI 7.3 View.

I tried to change it to 7.3 view using Utilities -> Settings -> Proxy generation in the proxy Editor.

Connection to the Service Repository - > all checks working as expected.

Is it an error?

is there a way to get the previous look like 7.3? please help me to find?

Regards,

Siva.

PI7.4_Sproxy.png (13.8 kB)
PI7.3_Sproxy.png (17.5 kB)
Add a comment
10|10000 characters needed characters exceeded

Related questions

4 Answers

  • Best Answer
    Posted on May 27, 2015 at 06:57 AM


    This is not an error.In 7.4 we see it this way.Even in my systems I see the same.

    Please follow this :

    sproxy->Source->ESR->SWC

    Dont go to ESR(local)

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on May 27, 2015 at 07:18 AM

    Edit: I see you already found the answer.

    As Dilip mentions, this is the way SPROXY will look when connecting to PI 7.4. To further clarify Dilip's answer, this is where you find your SWC and Service Provider and Service Consumer for your inbound and outbound service interfaces:

    Br, Kenneth

    Message was edited by: Kenneth Eriksen


    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on May 27, 2015 at 06:41 AM

    Hi Siva,

    Please check if your backend configs are updated to point to new SAP PI system. In SM59 , check the Destination SAP_PROXY_ESR.

    Also check in SPROXY test connection, if its able to call the new ESR of PI system. Refer the following links for similar issue:

    Hope this helps

    Regards,
    Azhar

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Sep 12, 2016 at 04:54 AM

    Hi Siva,

    Yes it is,

    You can also change the view of repository from 7.4(new) to 7.3(old).

    Go to Utilities->Settings->Proxy Generation.

    Here you can find an drop down of Enterprise Service Browser.

    Select ESR Browser instead of Default Browser and press enter.

    Enjoy......

    Re award if it's helpful to you.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.