Skip to Content
0
Former Member
Jan 23, 2006 at 04:55 PM

Tracks for different Service Packs

10 Views

Hi,

We have been developing a Web Dynpro application with JDI Scenario 2+ on WAS 6.40 SP12. We recently released the product into production and decided to upgrade our JDI Server to SP15 but our other servers remain at SP12.

After the upgade to SP15 on the JDI Server, the SP15 archives were mistakenly checked-into the development track. Now when we build an SCA and attempt to deploy it to another machine that has not been upgraded to SP15 the deployment fails. Looking at the manifest in the SCA file it specifically requires SP15 versions of the SAP components.

I have tried to check-in the SP12 archives to the track but when doing so I receive the following error:

com.sap.cms.util.exception.checkin.CMSKAlreadyCheckInException: Component (Vendor/Name/Location/Counter sap.com/SAP-JEE/NIGHTLYBUILD/20050422042400) specified in the file (D:\usr\sap\JTrans\CMS\inbox\SAP-JEE_SP12.sca) is already imported into the system (Domain/Name Tst/MRCMO_D)

Any suggestions on how I can change this track back to building archives that requires SP12 instead of requiring SP15?