Skip to Content
avatar image
Former Member

Twitter adapter Smart Data Integration - SAP DBTech JDBC: [403]: internal error: Cannot get remote source objects: proxy

We are currently exploring SAP HANA Smart Data Integration and have followed videos on SAP HANA Academy for getting started with the Twitter adapter.  When we get to the point to test the connection from creating a new Remote Source we receive the following error:

SAP DBTech JDBC: [403]: internal error: Cannot get remote source objects: proxy

Our IT Admin had the following comment:

If both the HANA and Agent systems are on the same LAN w/o a firewall between then, then there shouldn't be a need for a proxy.


My questions:


Is there a way to get the Twitter Adapter to work with SAP HANA Smart Data Integration that does not require a proxy to be setup?

If a proxy is required at all times to use this functionality, what is the reasoning.

TwitterAdapter.jpg (70.6 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Best Answer
    avatar image
    Former Member
    Jun 17, 2015 at 09:05 PM

    Update for resolution

    (2) steps required to get this working without requiring a proxy

    1.  Change your TWITTER DEV account time-zone to the following setting:

    (GMT) UTC

    2.  Change the dpagentconfig.ini for the Data Provisioning Agent:

    The ini file by default has the following:

    • proxyHost=proxy
    • proxyPort=8080
    • proxyType=

    Changing the ini file with following allowed a successful test connection:

    • proxyHost=
    • proxyPort=
    • proxyType=


    Add comment
    10|10000 characters needed characters exceeded