Skip to Content
0
Former Member
May 22, 2015 at 10:40 AM

Unable to connect Database.

290 Views

Hello,

I have installed and configure the EP system as distributed.

But the CI is not able to connect DB. If i start SAP then its start but not with my DB it is just starting without my actual DB.

When i check R3trans -d, it is showing the below message :

This is R3trans version 6.14 (release 700 - 14.02.08 - 14:55:00).

unicode enabled version

2EETW169 no connect possible: "DBMS = ORACLE --- dbs_ora_tnsname = 'SID'"

R3trans finished (0012).

Then i checked the Trans.log so it is showing the below error :

4 ETW000 R3trans version 6.14 (release 700 - 14.02.08 - 14:55:00).

4 ETW000 unicode enabled version

4 ETW000 ===============================================

4 ETW000

4 ETW000 date&time : 22.05.2015 - 15:44:02

4 ETW000 control file: <no ctrlfile>

4 ETW000 R3trans was called as follows: R3trans -d

4 ETW000 trace at level 2 opened for a given file pointer

4 ETW000 [dev trc ,00000] Fri May 22 15:44:02 2015 78 0.000078

4 ETW000 [dev trc ,00000] db_con_init called 17 0.000095

4 ETW000 [dev trc ,00000] create_con (con_name=R/3) 36 0.000131

4 ETW000 [dev trc ,00000] Loading DB library '/usr/sap/SID/SYS/exe/run/dboraslib.o' ...

4 ETW000 44 0.000175

4 ETW000 [dev trc ,00000] load shared library (/usr/sap/SID/SYS/exe/run/dboraslib.o), hdl 0

4 ETW000 4840 0.005015

4 ETW000 [dev trc ,00000] Library '/usr/sap/SID/SYS/exe/run/dboraslib.o' loaded

4 ETW000 25 0.005040

4 ETW000 [dev trc ,00000] function DbSlExpFuns loaded from library /usr/sap/SID/SYS/exe/run/dboraslib.o

4 ETW000 27 0.005067

4 ETW000 [dev trc ,00000] Version of '/usr/sap/SID/SYS/exe/run/dboraslib.o' is "700.08", patchlevel (0.324)

4 ETW000 400 0.005467

4 ETW000 [dev trc ,00000] function dsql_db_init loaded from library /usr/sap/SID/SYS/exe/run/dboraslib.o

4 ETW000 25 0.005492

4 ETW000 [dev trc ,00000] function dbdd_exp_funs loaded from library /usr/sap/SID/SYS/exe/run/dboraslib.o

4 ETW000 65 0.005557

4 ETW000 [dev trc ,00000] New connection 0 created 22 0.005579

4 ETW000 [dev trc ,00000] 0: name = R/3, con_id = -000000001 state = DISCONNECTED, perm = YES, reco = NO , timeout = 000, con_max = 255, con_opt = 255, occ = NO

4 ETW000 29 0.005608

4 ETW000 [dev trc ,00000] db_con_connect (con_name=R/3) 41 0.005649

4 ETW000 [dev trc ,00000] find_con_by_name found the following connection for reuse:

4 ETW000 25 0.005674

4 ETW000 [dev trc ,00000] 0: name = R/3, con_id = 000000000 state = DISCONNECTED, perm = YES, reco = NO , timeout = 000, con_max = 255, con_opt = 255, occ = NO

4 ETW000 26 0.005700

4 ETW000 [dev trc ,00000] Got LIBPATH=/usr/lib:/lib:/usr/sap/SID/SYS/exe/run:/oracle/client/10x_64/instantclient from environment

4 ETW000 391 0.006091

4 ETW000 [dev trc ,00000] -->oci_init1 17 0.006108

4 ETW000 [dev trc ,00000] Oracle Client Version: '10.2.0.4.0', (dbsl 700 131011, UNICODE[2])

4 ETW000 123 0.006231

4 ETW000 [dev trc ,00000] Default connection: tnsname ='SID' 14 0.006245

4 ETW000 [dev trc ,00000] -->oci_initialize(con=0, char='UTF16', nchar='AL16UTF16', uc_ln=2)

4 ETW000 25 0.006270

4 ETW000 [dev trc ,00000] Application info callback registered. 14 0.006284

4 ETW000 [dev trc ,00000] ➖ OCIEnvCreate(mode=16384=OCI_UTF16) returned 0 (for default NLS handle)

4 ETW000 1457 0.007741

4 ETW000 [dev trc ,00000] OCIHandleAlloc(OCI_HTYPE_ERROR, con=0, ErrHp=0x110fac518)

4 ETW000 311 0.008052

4 ETW000 [dev trc ,00000] OCIHandleAlloc(OCI_HTYPE_ERROR, con=0, ErrBt=0x110fabdc8)

4 ETW000 27 0.008079

4 ETW000 [dev trc ,00000] NLS env.: lang=0041004D00450052004900430041004E 127 0.008206

4 ETW000 [dev trc ,00000] terr=0041004D00450052004900430041 20 0.008226

4 ETW000 [dev trc ,00000] char=00550054004600310036 17 0.008243

4 ETW000 [dev trc ,00000] Client NLS setting (by OCINlsGetInfo): con=0, 'AMERICAN_AMERICA.UTF16'

4 ETW000 24 0.008267

4 ETW000 [dev trc ,00000] charset='UTF16', ncharset='AL16UTF16', UNI_ASC=FALSE

4 ETW000 23 0.008290

4 ETW000 [dev trc ,00000] Logon as OPS$-user to get SAPR3's password 16 0.008306

4 ETW000 [dev trc ,00000] Connecting as /@SID on connection 0 (nls 0) ... (dbsl 700 131011, UNICODE[2])

4 ETW000 25 0.008331

4 ETW000 [dev trc ,00000] Allocating service context handle for con=0 27 0.008358

4 ETW000 [dev trc ,00000] Allocating server context handle 17 0.008375

4 ETW000 [dev trc ,00000] Attaching to DB Server SID (con=0,svchp=0x110faf6b8,srvhp=0x110faf8d8)

4 ETW000 65 0.008440

4 ETW000 [dev trc ,00000] Fri May 22 15:44:03 2015 43647 0.052087

4 ETW000 [dev trc ,00000] Assigning server context 0x110faf8d8 to service context 0x110faf6b8

4 ETW000 37 0.052124

4 ETW000 [dev trc ,00000] Allocating user session handle 41 0.052165

4 ETW000 [dev trc ,00000] Starting user session: OCISessionBegin(con=0, usr='/',svchp=0x110faf6b8, srvhp=0x110faf8d8, usrhp=0x111030320)

4 ETW000 38 0.052203

4 ETW000 [dev trc ,00000] Assigning user session 0x111030320 to service context 0x110faf6b8

4 ETW000 7011 0.059214

4 ETW000 [dev trc ,00000] -->oci_prepare_stmt(con=0, len=52, stp=0x110fb9288)

4 ETW000 60 0.059274

4 ETW000 [dev trc ,00000] BEGIN DBMS_APPLICATION_INFO.SET_MODULE(:A0,:A1);END;

4 ETW000 27 0.059301

4 ETW000 [dev trc ,00000] - oci_bind ( 0: SQLT_STR, l=600, con=0, stp=0x110fb9288, vp=0x9001000a78d40cc,ip=0x9001000a78d3d00,rlp=(nil),rcp=(nil))

4 ETW000 79 0.059380

4 ETW000 [dev trc ,00000] - oci_bind ( 1: SQLT_STR, l=600, con=0, stp=0x110fb9288, vp=0x9001000a78d3e74,ip=0x9001000a78d3d02,rlp=(nil),rcp=(nil))

4 ETW000 33 0.059413

4 ETW000 [dev trc ,00000] CbApplInfoGet() failed (ignored 1). 18 0.059431

4 ETW000 [dev trc ,00000] -->oci_prepare_stmt(con=0, len=54, stp=0x110fba2e0)

4 ETW000 25 0.059456

4 ETW000 [dev trc ,00000] BEGIN DBMS_APPLICATION_INFO.SET_CLIENT_INFO(:A0); END;

4 ETW000 24 0.059480

4 ETW000 [dev trc ,00000] - oci_bind ( 0: SQLT_STR, l= 40, con=0, stp=0x110fba2e0, vp=0x9001000a78d3d60,ip=(nil),rlp=(nil),rcp=(nil))

4 ETW000 894 0.060374

4 ETW000 [dev trc ,00000] -->oci_execute_stmt(con=0, stp=0x110fba2e0, iters=1, rowoff=0, dml_batch_errors=0)

4 ETW000 32 0.060406

4 ETW000 [dev trc ,00000] <--oci_execute_stmt(rc=0, iters-errors = 1-0) [time 0,001s]

4 ETW000 557 0.060963

4 ETW000 [dev trc ,00000] -->oci_prepare_stmt(con=0, len=0, stp=0x110fba2e0)

4 ETW000 37 0.061000

4 ETW000 [dev trc ,00000] SELECT SID FROM V$MYSTAT WHERE ROWNUM<2

4 ETW000 25 0.061025

4 ETW000 [dev trc ,00000] -->oci_define ( 0: SQLT_INT, l= 4, con=0, stp=0x110fba2e0, vp=0xfffffffffffe5e4,ip=0xfffffffffffe5e0,rlp=(nil),rcp=(nil))

4 ETW000 36 0.061061

4 ETW000 [dev trc ,00000] -->oci_execute_stmt(con=0, stp=0x110fba2e0, iters=1, rowoff=0, dml_batch_errors=0)

4 ETW000 31 0.061092

4 ETW000 [dev trc ,00000] OCIStmtExecute() failed with -1=OCI_ERROR 1278 0.062370

4 ETW000 [dev trc ,00000] SQL error 942: 18 0.062388

4 ETW000 [dev trc ,00000] ORA-00942: table or view does not exist

4 ETW000 26 0.062414

4 ETW000 [dev trc ,00000] <--oci_execute_stmt(rc=942, iters-errors = 1-0) [time 0,001s]

4 ETW000 27 0.062441

4 ETW000 [dev trc ,00000] Could not read session ID from V$MYSTAT. rc=-1. 17 0.062458

4 ETW000 [dev trc ,00000] Now '/@SID' is connected: con=0, nls_hdl=0, session_id=-1.

4 ETW000 24 0.062482

4 ETW000 [dev trc ,00000] -->oci_prepare_stmt(con=0, len=0, stp=0x110fba2e0)

4 ETW000 27 0.062509

4 ETW000 [dev trc ,00000] ALTER SESSION SET NLS_SORT = BINARY

4 ETW000 25 0.062534

4 ETW000 [dev trc ,00000] -->oci_execute_stmt(con=0, stp=0x110fba2e0, iters=1, rowoff=0, dml_batch_errors=0)

4 ETW000 31 0.062565

4 ETW000 [dev trc ,00000] <--oci_execute_stmt(rc=0, iters-errors = 1-0) [time 0,000s]

4 ETW000 264 0.062829

4 ETW000 [dev trc ,00000] -->oci_prepare_stmt(con=0, len=0, stp=0x110fba2e0)

4 ETW000 32 0.062861

4 ETW000 [dev trc ,00000] SELECT USERID,PASSWD FROM SAPUSER WHERE USERID IN (:A0,:A1)

4 ETW000 25 0.062886

4 ETW000 [dev trc ,00000] - oci_bind ( 0: SQLT_STR, l=256, con=0, stp=0x110fba2e0, vp=0x9001000a7ad9738,ip=(nil),rlp=(nil),rcp=(nil))

4 ETW000 39 0.062925

4 ETW000 [dev trc ,00000] - oci_bind ( 1: SQLT_STR, l=256, con=0, stp=0x110fba2e0, vp=0xfffffffffffe2cc,ip=(nil),rlp=(nil),rcp=(nil))

4 ETW000 7154 0.070079

4 ETW000 [dev trc ,00000] -->oci_define ( 0: SQLT_STR, l=512, con=0, stp=0x110fba2e0, vp=0xfffffffffffe4cc,ip=0xfffffffffffe080,rlp=(nil),rcp=(nil))

4 ETW000 126 0.070205

4 ETW000 [dev trc ,00000] -->oci_define ( 1: SQLT_AFC, l=512, con=0, stp=0x110fba2e0, vp=0xfffffffffffe6cc,ip=0xfffffffffffe082,rlp=(nil),rcp=(nil))

4 ETW000 35 0.070240

4 ETW000 [dev trc ,00000] -->oci_execute_stmt(con=0, stp=0x110fba2e0, iters=1, rowoff=0, dml_batch_errors=0)

4 ETW000 56 0.070296

4 ETW000 [dev trc ,00000] OCIStmtExecute() failed with -1=OCI_ERROR 748 0.071044

4 ETW000 [dev trc ,00000] SQL error 942: 34 0.071078

4 ETW000 [dev trc ,00000] ORA-00942: table or view does not exist

4 ETW000 36 0.071114

4 ETW000 [dev trc ,00000] <--oci_execute_stmt(rc=942, iters-errors = 1-0) [time 0,001s]

4 ETW000 27 0.071141

4 ETW000 [dbsloci. ,00000] *** ERROR => ORA-942 when accessing table SAPUSER

4 ETW000 31 0.071172

4 ETW000 [dev trc ,00000] set_ocica() -> SQL error code 942 24 0.071196

4 ETW000 [dev trc ,00000] -->oci_get_errmsg (con=0, rc=942) 27 0.071223

4 ETW000 [dev trc ,00000] OCIErrorGet -> SQL error code: 942 42 0.071265

4 ETW000 [dev trc ,00000] ORA-00942: table or view does not exist

4 ETW000 46 0.071311

4 ETW000 [dev trc ,00000] Disconnecting from connection 0 ... 14 0.071325

4 ETW000 [dev trc ,00000] Rolling back transaction ... 25 0.071350

4 ETW000 [dev trc ,00000] Closing user session (con=0,svchp=0x110faf6b8,usrhp=0x111030320)

4 ETW000 234 0.071584

4 ETW000 [dev trc ,00000] Disconnected (con=0) from ORACLE. 417 0.072001

4 ETW000 [dev trc ,00000] Info: 99=DBSL_ERR_DB, oerr=942, try to connect with default password.

4 ETW000 43 0.072044

4 ETW000 [dev trc ,00000] Connecting as SAPR3/<pwd>@SID on connection 0 (nls 0) ... (dbsl 700 131011, UNICODE[2])

4 ETW000 26 0.072070

4 ETW000 [dev trc ,00000] Assigning username to user session: con=0, usrhp=0x111030320

4 ETW000 24 0.072094

4 ETW000 [dev trc ,00000] Assigning password to user session: con=0, usrhp=0x111030320

4 ETW000 27 0.072121

4 ETW000 [dev trc ,00000] Starting user session: OCISessionBegin(con=0, usr=SAPR3/<pwd>, svchp=0x110faf6b8, srvhp=0x110faf8d8, usrhp=0x111030320)

4 ETW000 145 0.072266

4 ETW000 [dev trc ,00000] OCISessionBegin(OCI_DEFAULT) failed with -1=OCI_ERROR

4 ETW000 3301 0.075567

4 ETW000 [dev trc ,00000] OCISessionBegin(OCI_DEFAULT) failed with SQL error 1017:

4 ETW000 107 0.075674

4 ETW000 [dev trc ,00000] ORA-01017: invalid username/password; logon denied

4 ETW000 27 0.075701

4 ETW000 [dbsloci. ,00000] *** ERROR => CONNECT failed with sql error '1017'

4 ETW000 26 0.075727

4 ETW000 [dev trc ,00000] set_ocica() -> SQL error code 1017 14 0.075741

4 ETW000 [dev trc ,00000] -->oci_get_errmsg (con=0, rc=1017) 15 0.075756

4 ETW000 [dev trc ,00000] OCIErrorGet -> SQL error code: 1017 41 0.075797

4 ETW000 [dev trc ,00000] ORA-01017: invalid username/password; logon denied

4 ETW000 26 0.075823

4 ETW000 [dblink ,00431] ***LOG BY2=>sql error 1017 performing CON [dblink#5 @ 431]

4 ETW000 61 0.075884

4 ETW000 [dblink ,00431] ***LOG BY0=>ORA-01017: invalid username/password; logon denied [dblink#5 @ 431]

4 ETW000 25 0.075909

2EETW169 no connect possible: "DBMS = ORACLE --- dbs_ora_tnsname = 'SID'"

Please help.