Skip to Content
author's profile photo Former Member
Former Member

Chip 'My Info' doesn't work correct

Hi experts,

we have implemented HR Renewal 2.0 FP2. on NWBC.

In ESS/MSS we have now problems with chip 'My Info'. We doesn't seen the photo of the employee, only information of name, vacation and incomplete time recording.

If we start leave request, all work's fine. But if we start the employe Profil, there aren't any data exxept the employee number and name. If we start the organization Chart, there are a blank window without any data.

The Gateway error_log Shows error: the request URL or the metadata Definition is incorrect.

Any idea what might be the reason of this problem?

Thanks a lot!

Regards,

Claudia Janecek

employee_profil.jpg (234.7 kB)
error_log.jpg (561.0 kB)
Add a comment
10|10000 characters needed characters exceeded

Related questions

2 Answers

  • Posted on May 25, 2015 at 08:09 PM

    the note above 1797736 talks about gateway errors, you can download the pdf, as its general guidebook as it might be some services are not activated etc in your case and hence you see incorrect results. you can do a Http trace or developer trace using f12 too

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on May 27, 2015 at 07:23 AM

    Dear Siddharth,

    thanks for your reply. We have almost check note 1797736 and error log, but there aren't good informations which will solve the problem.

    We have implemented the odata Services: /ui2/launchpad, if we load the metadata, there aren't any errors.

    If we start the request-uri: /sap/opu/odata/ui2/launchpad in sap netweaver Gateway Client, the status is ok.

    If we start the request-uri (which is on error in the error log): /sap/opu/odata/ui2/launchpad/result?$skip=0&$top=10&$inlinecount=allpages the code 404 not found is displayed.

    We have analysed, that the error is processed in method: /IWFND/IF_MED_MDL_SERVICES_GRP-get_entity_set.

    The documantation of this method explain, that, if the entry not found, the corresponding model (metatdata) ist corrupt. Most likely caused by a coding error in the BEP meta data Provider class.

    But we still have implemented the standard odata Services, not done any modifications.

    Could you help here?

    Thanks a lot!

    Best Regards,

    Claudia Janecek

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Zelalem Tadesse

      Dear Zelalem Tadesse,

      it was an error in Customizing. Table V_T77TMCDRCNFFLD was not correct customized. I have implemented fields and Infotyp - what I doesn't now is that you should not Change the sequence of the fields.

      Hope I can Held you!

      Kind regards,

      Claudia Janecek

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.