Skip to Content
author's profile photo Former Member
Former Member

Report refreshing for long time

I have a record count of 45,000 . I followed the best practices to create the universe and report( Webi Report) .But still my report is taking 45 seconds. Please let me know how to optimize the time , the report runs.

All my users want report less than 7 seconds.

Even I changed the settings in the universe designer:

Limit the size of result set to 50.000.

Looking forward for your inputs.

Thanks,

Prathyusha.

seconds.PNG (8.6 kB)
time.PNG (36.1 kB)
Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • author's profile photo Former Member
    Former Member
    Posted on May 19, 2015 at 07:47 PM

    just try to run your SQL script generated by WEBI report on database.

    After running compare the time taken to run query.

    If there is no difference in time then there would be issue in query you have to optimize it.

    Or else just provide more info about query to us so that we can help

    Add a comment
    10|10000 characters needed characters exceeded

    • 1. "By default, BusinessObjects sorts from the lighter to the heavier tables (tables with the least amount of rows to those with the most). This affects the way that tables are ordered in the FROM clause of the SQL statement. The way that tables are sorted at the database level depends on your database."

      To allocate Oracle table weight for better report based on Oracle db performance, for example,

      D:\Program Files\Business Objects\BusinessObjects Enterprise 12.0\win32_x86\dataAccess\connectionServer\jdbc\oracle.prm

      D:\Program Files\Business Objects\BusinessObjects Enterprise 12.0\win32_x86\dataAccess\connectionServer\jdbc\oracle9.prm

      D:\Program Files\Business Objects\BusinessObjects Enterprise 12.0\win32_x86\dataAccess\connectionServer\oracle\oracle.prm

      D:\Program Files\Business Objects\BusinessObjects Enterprise 12.0\win32_x86\dataAccess\connectionServer\oracle\oracle9.prm

      - edit each oracle.prm file, change the REVERSE_TABLE_WEIGHT value to N from Y.

      See http://studentworld4u.blogspot.com/2009/05/performance-tuning.html for detail.

      Also see SAP KB 1181398 - Reverse_Table_Weight parameter not working for Oracle on http://service.sap.com/sap/support/notes/1181398 that "The Reverse_Table_Weight parameter works only when the Outerjoins_Generation parameter is set to ANSI_92."

      2. check "Query Stripping" from the "Document Property" in your Webi report.

      At last, check out Tips for Optimizing the Performance of Web Intelligence Documents on http://scn.sap.com/docs/DOC-58571.

      Hope this helps,

      Jin-Chong

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.