Skip to Content
author's profile photo Former Member
Former Member

Issue while creating material due to classification status

Hi,

In my system, I am not able to create a material with classification data under certain circumstance. While entering data in MM01 for a material with classification data, I enter class assignment information and do not enter the class status. i.e. it is set as Blank. If this is the case, the material gets saved.

However, if the same information is entered but this time i try to set the class status as 'Released'(under assignment subheading), the material does not get saved, there is no error message coming up from the system and the status blanks out on its own. I need to know about the class status and its behaviour while creating Material master because, I am facing a critical issue where the system automatically picks up the material class status as 'Released' and the system neither saves the material, nor does it give an error. Can someone please shed some light on this.

Appreciate your help at the earliest.

Thanks and regards,

Akshatha Rao.

Add a comment
10|10000 characters needed characters exceeded

Related questions

2 Answers

  • Posted on May 18, 2015 at 10:17 AM

    Hi Akshatha,

    In customizing check what are the setting for classification status. Which status is default and how it behaves. You can check this under below path

    Cross-Application Components - Classification System - Classes - Maintain Object Types and Class Types. (check the screen shot)

    It seems in your system the default is blank.


    Class.JPG (44.2 kB)
    Add a comment
    10|10000 characters needed characters exceeded

    • Hi Akshatha,

      As per your screen shot it seems status 5 is blank and it has configuration "incomplete system" & "auto release" which I think is creating this issue (and 5th being default). If you check documentation for these two check boxes this is what it say's;

      "Release Automatically

      This indicator enables automatic release of classifications.

      You can only set this indicator in conjunction with another status indicator. If you set the indicator together with status indicator "Incomplete system", a classification that was locked automatically can be released automatically.

      The system checks whether the classification is complete (all required characteristics have values) and consistent."

      It seems the bold highlighted is creating issue. If you see my screen shot it has only check box on incomplete system.

      I would suggest you to check with functional consultant who changed this or change the same and do thorough testing (though recommend first to understand why it was put that way in first place)

      Let me know if it helps.

      Regards

      Rahul

  • Posted on May 18, 2015 at 10:10 AM

    It is strange. My system is not allowing to to set the status as blank neither in class (CL02) nor in material master.

    Even though, there are no way to create a blank status (with combination of class type) for drop down list from IMG SPRO-IMG-SAP NetWeaver-Application Server-IDoc Interface / Application Link Enabling (ALE)-Modelling and Implementing Business Processes-Configure Predefined ALE Business Processes-Logistics-Master Data Distribution-Integrated Distributed PDM Solution (ID PDM)-Object Status-Define class status.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.