Skip to Content
author's profile photo Former Member
Former Member

Kapsel App configuration through Afaria app policy

We are attaching, the configuration file to a Kapsel application through Afaria, but when we open it on a device, it is unable to fetch registration details like servername, port , etc.

We are using relay server for SMP server.

Please find below screenshot of config file.

Any ideas on what we are doing wrong?

Regards,

SN

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

2 Answers

  • Posted on May 13, 2015 at 11:45 AM

    Suraj,

    Is this an iOS application? The only time I have seen a configuration settings file not apply is when the APP ID wasn't put into the application policy for the app. Is this an enterprise or an appstore/Google play app?

    Tracy Barkley

    SAP Active Global Support

    Sr Tech Support Engineer

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Tracy,

      Its a enterprise Kapsel app for Android device.

      Software versions used are:

      SMP 3.0 SDK version : 3 SP 06

      Afaria version : 7 SP 05

      SMP 3.0 Server version : 3 SP 05

      Android version : 5.0.2

      Regards,

      SN

  • author's profile photo Former Member
    Former Member
    Posted on May 18, 2015 at 09:25 AM

    Anyone has an idea on this?

    Regards,

    SN

    Add a comment
    10|10000 characters needed characters exceeded

    • Hi, Suraj.

      When you launch your Kapsel application, do you see any corresponding entries for the Package Server's application directory in your IIS log (default path: c:\inetpub\logs\LogFiles\w3svc1)? Typically you should see a line similar to the below in your IIS log from where the Afaria Client is reaching out to the Package Server to retrieve the configuration data:

      GET /ps/ps.svc/package/content/<DeviceID>/<PolicyID>/16/TEXT_FILE_<FileName>

      If you're not seeing that line either the Kapsel app is not calling the Afaria SLL properly or the device is unable to reach the Afaria Package Server. For the latter, check the Afaria Client configuration and make sure the values for the Package Server address/port/etc. are correct. Also, since you're using the Relay Server, be sure to check the Relay Server's web server log (IIS/Apache) to see if the request ever reaches the Relay Server.

      For issues with the actual Kapsel configuration, be sure it's set properly to call out to the Afaria Client. Here is a help page with details:

      http://help.sap.com/saphelp_smp307sdk/helpdata/en/7c/03512370061014b290bfa28ca81498/frameset.htm

      Thanks,

      Keith Nunn
      SAP Active Global Support

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.