Skip to Content
author's profile photo Former Member
Former Member

Creating navigational attribute

Hi all,

I have a master data attribute named "CUSTOMER", whitch have an attribute named "ADDRESS" and this one have an attribute named "REGION"(view attached image).

I marked "REGION" as navigational attribute but it doesn't appear among the list of navigational attributes in cube maintenance window.

Thanks.

BW.png (64.1 kB)
Add a comment
10|10000 characters needed characters exceeded

Related questions

5 Answers

  • Best Answer
    Posted on May 12, 2015 at 10:07 AM

    Hi,

    You need to add CUSTADR as separate infoobject in Cube then only you will get REGION in navigational attribute list.

    Regards,

    Vengal.

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on May 12, 2015 at 10:04 AM

    Hi,

    at Cube level which info object you added?

    ZCUSTOMER or CUSTADR?

    if you added ZCUSTOMER then it won't show region navigation attribute.

    Because region is navigational attribute or custadr(address).

    Thanks

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on May 12, 2015 at 10:15 AM

    Hi Nassim,

    Region is the navigation attribute of Address, so you need to add Address in Cube then you will able to use its Navigation attribute 'Region'


    If you try to use region without adding Address(CUSTADR) then it will not allow because Region is not navigation attribute of Customer(0Customer)


    Thanks,

    Kashif Ali Khan


    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on May 12, 2015 at 11:00 AM

    Thank you all,

    Now by adding CUSTADR, "REGION" appear as navigational attribute but, when I put it in bex query, I obtain an empty field.

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hello Nassim,

      To get attribute data in the report...you need to you need to do following...

      Characteristics:

      ZCUSTOMER

      CUSTADR

      REGION

      First you have to load Master data for ZCUSTOMER using some datasource, with this you will get data for ZCUSTOMER as well as CUSTADR

      Second, you have to load master data for CUSTADR from another datasource or same...with this you will get data for CUSTADR and REGION which is an attribute to CUSTADR...

      Third,

      Add ZCUSTOMER & CUSTADR to the Infocube you required. In Navigational attributes, Tick ZCUSTOMER__CUSTADR as navigational attribute & CUSTADR__REGION also as navigational attribute.

      Hopefully, you see data now in Report...

      Thanks

      Ajay.D

  • Posted on May 13, 2015 at 04:11 AM

    Hi Jloud,

    You did modeling. After that for loading data into info cube you have to first load master data for address and take region as navigational attribute and then load master data for customer and take attribute address. Now load data into info cube.

    You should do reporting on info set because its a transitive attribute reporting. Take Info cube and Characteristics info object with master data (Address) and keep Address as joining condition.

    Hopefully it will get execute.

    Regards,

    Swapna Jain

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.