Skip to Content
author's profile photo Former Member
Former Member

Crystal Reports LOV

Hi experts,

We are facing a problem, when we are using a Crystal Reports with
parameters based on a Business View.
The Business View has a SSO connection so the row level security can be
guaranteed.

If more than one user at the same time opens the report, sometimes the
Parameter shows the values of another user.


Actually the parameter should request new data from the DB. But it
seems, that he gets the value out of the cache.

Informations about the Business View:

Connection:
User: Empty
Password: Empty
SSO: True

List of Value:
Oldest On-Demand Data Given to Clients (seconds): 0

We proved the SAP Note "1531909 - Business View row level security
doesn't work" without any success.

Our enviroment:
BO XI3.1 SP7.2
Crystal Reports 2008 (12.7.0.1983)

Steps for reconstruction:
1. Open a Crystal Reports with a parameter based on a Business View
(with row level security)
2. User A opens the report. The parameter LOV shows the profit center
of him.
3. At the same time User B opens the report. The parameter LOV shows
the profit center of User A.

Are in this case still different settings required ?

Thx for any support!

Mike

Add a comment
10|10000 characters needed characters exceeded

Related questions

4 Answers

  • author's profile photo Former Member
    Former Member
    Posted on May 12, 2015 at 05:34 PM

    I think there are additional options (can't remember 3.1 specifically), but look for something like "Viewer Refresh Always Yields Current Data". If there are separate processing and cache servers, you'd have to set both the same for the desired effect. You can also set some options on the reports themselves, which will override what is set on the servers.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on May 12, 2015 at 07:03 PM

    Make sure the option 'Share Report Data Between Clients' is unchecked on crystal cache and processing server

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on May 13, 2015 at 10:16 AM

    Hi Brian, and Ravi

    thx for reply!

    We checked those settings and compared that we have the same settings on the processing and cache server.

    Unfortunately, the issue is not solved.. we got different profitcenters if we logged in with two users and different rights/roles. Therefore a user sees profitcenters on which he is not autorized..

    any other ideas?

    Thx,

    Mike

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      If none of those work, you may want to trace the queries and see if they are being executed at the DB each time or still being cached somewhere on the BI system.

      Also, check out this thread, it may give you ideas of other places to check

  • author's profile photo Former Member
    Former Member
    Posted on May 13, 2015 at 04:24 PM

    Normally that's the option which causes this behavior. I believe you must have also set the same at report level?

    Also in Report Application Server try setting Oldest On-Demand Data Given to Clients (seconds): 0

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Pavi

      Thx for your input!

      I also changed in Reports application server the "oldest On-Demand Data Given to Clients" to 0.

      But we still got the same behavior..

      Do you have perhaps some other ideas ?

      Thx a lot!

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.