Skip to Content

Reg: SqlPlus Error

Dear Team,

  We are encountering below issue when we execute the brtools and sqlplus in SIDadm . In Oracle adm its everything working fine  we verifed the permisson everything seems to be ok ,

Kindly help  to resolve the issue


Sidadm 3% sqlplus / as sysdba

SQL*Plus: Release 11.2.0.3.0 Production on Sun May 10 18:01:00 2015

Copyright (c) 1982, 2011, Oracle.  All rights reserved.

ERROR:

ORA-12547: TNS:lost contact

Enter user-name:

ERROR:

ORA-12547: TNS:lost contact

Enter user-name:

ERROR:

ORA-12547: TNS:lost contact

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

6 Answers

  • avatar image
    Former Member
    May 10, 2015 at 03:40 PM

    Hi Kishore,

    Hope you searched before posting as you could get lots of possible resolutions for the issue message

    ORA-12547: TNS:lost contact

    Anyways could you confirm for the value for ulimit,if it's low then set the value with unlimited .Second is to maintain the correct permissions & ownerships for $ORACLE_HOME/bin/  as well as for the other files.

    Addition to it follow SAP Note  505630 - Composite SAP Note ORA-12547

    Hope this will resolve your issue.

    Wish you the best !!

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Gaurav

      I have searched many forums for this issue , In our scenario we are able to execute brtools and Sqlplus in ORASID , But when we tried with SIDadm we are getting this error.

      We cross verified the permission and Ulimt ,group everything  seems to be ok, System was working fine suddenly we encountered this issue .

      Regards,

      KIshore

  • avatar image
    Former Member
    May 11, 2015 at 08:00 AM

    Hi Kishore,

    Check the below things

    - Goto /oracle/SID/112_64/bin and check the permission on the oracle file.

      It should have a sticky bit on the oracle file generally 6451

    or run the root.sh file which will set the required permission.

    If the above permission is ok , then check the tnsnames.ora.

    also do paste the screenshot of the permission of oracle file.

    With Regards

    Ashutosh Chaturvedi

    Add comment
    10|10000 characters needed characters exceeded

  • May 11, 2015 at 09:10 AM

    Hi,

    This can happen if the machine is overloaded.

    The below reason can fix your issue.

    • Bad kernel parameters settings (e.g. "ulimit" set too small)
    • Incorrect permissions on the ORACLE executable ($ORACLE_HOME/bin/oracle.exe)
    • $ORACLE_HOME/rdbms/lib/config.o is 0 bytes
    • Oracle binaries have not been linked correctly

    if everthing looks fine then login will ORS_SID and execute the below command as per your issue.


    $ relink all:

    I hope your issue will resolved.

    Thanks,

    BM

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Kishor,

      Echoing Siddhesh, do verify your listerner.ora & tnsnames.ora files for the hostname and see if your using any virtual name or physical hostnames.

      also Do verify if your having any local_listener parameter in your spfile. if yes, the do confirm us if your using local listerner or a SID specific one. You can get this details by Listner name.

      and check for the process listner and which ports its referring too.

      Let us know the outcome/checks.

      Regards,

      Ram

  • avatar image
    Former Member
    May 10, 2015 at 04:29 PM

    Hello Kishore,

    1. Is this is fresh install ?

    2. What flavor of unix are you on ?

    3. Does <sid>adm belong to groups dba and oper ?

    4. What is the ownership of and permissions of /oracle/<SID>/112_64/bin/oracle ?

    KR,

    Amerjit

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 06, 2015 at 01:50 PM

    Hi,

    Please check the Listener configuration if it is correct.

    Execute below steps

    1. stop db and listener

    2. run relink all from $ORACLE_HOME/bin

    3. start listener and db

    This should solve your issue...

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 07, 2015 at 09:11 AM

    is your issue solved? if not please mail me on skhule4@gmail.com so that we can check further..

    Add comment
    10|10000 characters needed characters exceeded