Skip to Content

What version of D3 is valid for both Vizpacker and Lumira - version 1.25.1 build 23

Hi,

I have updated to Lumira 1.25.1 build 3 - the free personal edition and now some of my extensions are broken running in Lumira.

The extensions that have broken rely on D3 version 2 and work in Vizpacker 1.25 with NO problems.

Running in Lumira it appears that a different version of d3 is in use from the errors in the console.

I hack all my extensions starting with Vizpacker and all the extensions work as expected in the test web pages with 1.25.

As the errors in Lumira 1.25 lead me to doubt the d3 version in use with Lumira, I created an extension just to display the d3 version in Vizpacker and Lumira.

So using the command d3.version in vizpacker shows version 2.10.0

Creating the extension in vizpacker and importing into Lumira shows d3 version as 3.4.12

So my thoughts are that I can update the d3 version vizpacker uses in the directory libs to match the Lumira one.

But I cant find any statement about the official d3 version with Lumira.

I have checked the visual extension guide

http://help.sap.com/businessobject/product_guides/vi01/en/lum_125_vp_en.pdf

whats new guide

http://help.sap.com/businessobject/product_guides/vi01/en/lum_125_whatsnew_en.pdf

I have checked the issues document as well and it mentions a differenct version of d3

http://help.sap.com/businessobject/product_guides/vi01/en/lum_125_restr_en.pdf

Does anyone know if d3 3.4.12 is the official version now with Lumira? If so can I update the vizpacker lib directory with a d3 version, but where should I download it from, maybe here Release 3.4.12 · mbostock/d3 · GitHub? Or have I missed something in the setup of 1.25.

Thanks

Robert

vizpackerD3.PNG (57.6 kB)
LumiraD3.PNG (19.8 kB)
Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

3 Answers

  • Best Answer
    Posted on Jun 20, 2015 at 09:44 PM

    In the end I have copied the version from Lumira into the vizpacker utility.

    Still not going to update all my extensions to version 3 code yet 😔. Will wait until a later release comes out and see if d3.v3 is the official supported version for lumira and vizpacker. Also tried the webIDE and that vizpacker tool is 2.10. Dissapointing......

    Tracked down d3 version in Lumira by setting up the dev tools and finding d3

    went to the source code and found d3.v3 and copied this code

    Copied this into d3.v2 in the vizpacker directory but did NOT change the filename - just changed the code inside.

    Ran the vizpacker utility from my computer and versions of d3 now match.

    Cant change the version in the WEB IDE though


    1.PNG (60.7 kB)
    2.PNG (23.0 kB)
    3png.PNG (8.2 kB)
    4.PNG (53.0 kB)
    5.PNG (51.5 kB)
    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on May 11, 2015 at 03:03 PM

    The link on

    http://saplumira.com/developers/ leads to version 3.5.5

    Add a comment
    10|10000 characters needed characters exceeded

    • Thanks Tony for the link but I saw that as the latest release of D3 and not the version supported by default in Lumira/vizpacker. At the moment I can't develop or fix my extensions with vizpacker as that has d3.v2 while Lumira is at d3.v3. Seems to me either vizpacker or the Lumira version has to change, I'd like to think vizpacker can be used with d3.v3 as that would be a better option and I can update my own extensions to work with d3.v3.

      Regards

      Robert

  • Posted on May 13, 2015 at 05:13 AM

    Hi Robert,

    Lumira uses require.js for dependency management. You can use that and include the new verison of D3 along with your extension bundle.

    Regards

    Shankar

    Add a comment
    10|10000 characters needed characters exceeded

    • Hi Shankar,

      Thanks for the comment , I know about the require.js dependency management.

      However seems to me that it does not makes sense to use require.js to match versions of d3 in Lumira and vizpacker.

      I fail to understand why Vizpacker and Lumira use different versions of d3 in version 1.25.

      Regards

      Robert

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.