Skip to Content
0

SLT Replication with Oracle Source

Jan 31, 2017 at 11:14 AM

285

avatar image
Former Member

Hi everyone,

I am trying to create a configuration with Oracle as Source. I already created the DB Connection in DBACOCKPIT and the connection is established succesfully. But when I try to create the configuration and the SLT asks me to enter a schema, I get the following error message:

In the DBACOCKPIT, I used the same schema name and the test was fine. So I don't get the problem.

Does anyone have an idea?

Thanks in advance.

Best regards,

Scott

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

5 Answers

Best Answer
avatar image
Former Member May 05, 2017 at 01:05 PM
0

The solution:

The User used to create the DBConnection needs the permission to read the view DBA_USERS. In this way, the SLT checks if the schema is existing in the database.

Best regards

Ulf

Share
10 |10000 characters needed characters left characters exceeded
James Zhang
Feb 02, 2017 at 07:11 AM
0

Hi Scott,

name is case sensitive, did you check this point?

Please let me know the output of following sql from oracle source:

select username from dba_users;

Best regards,
James

Show 2 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Hi James,

I tried every option. In capital letters and in small type letters. It didn't work.

Here is the result set of my SQL statement:

I thought about an authorization issue. My DB Connection is using the system user.

0

Yes, maybe this is permission issue, is it possible to have a look at the work process trace? Hopefully we can find more information.

0
avatar image
Former Member Feb 02, 2017 at 11:41 AM
0

Hi Scott

Try let's Schema Name and Tablespace Name unfilled if this fields not are mandatory.

Best regards

Show 1 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Hi Jose,

unfortunately the configuration requires the tablesspace and schema. I can't leve the fields blank.

0
Andrey Martynov
Feb 13, 2017 at 03:49 PM
0

Hi Scott,

I guess that problem can be connected with DB permissions of your user.
Please check the SAP Note 1771460 that describes required permissions for user in case when you use Oracle DB.

Kind regards

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Feb 28, 2017 at 01:37 PM
0

Hi,

I updated the SLT Server to the newest Support Package. Now it's working.

Thanks for all your help.

Regards,

Scott

Share
10 |10000 characters needed characters left characters exceeded