Skip to Content
avatar image
Former Member

No logon groups in SAP Logon

Hello everybody,

I have installed the sneakpreview abap and i'm trying to use a logon group. Everything is installed localhost. I'm able to assign a logon group to my instance in transaction 'smlg'. But when i try to connect, the logon group is not found. The message server is found, but gives the message that no logon group can be found.

Has anybody the same problem ?

What is the correct procedure to make a logon group work? Do i only have to add it in smlg or do i have to do somenthing else?

I need this logon group because i want to make jco connections and use these with web dynpro models adaptive rfc.

Thanks for the help



Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

4 Answers

  • Best Answer
    avatar image
    Former Member
    Jan 25, 2006 at 10:00 AM

    Don't know if you followed this procedure, you did not say, but this is what I would do after creating the logon group on smlg.

    In your c:\windows directory : Edit or create the file sapmsg.ini and Save it.

    Add the following lines (leave out the first one if already there):

    [Message Server]


    Now in the SAPLogon click on 'Groups...'

    On the next screen select your SID

    Now click on 'Generate List'

    Select you Logon Group

    Click on 'Add'

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      The group is assigned to the instance in smlg. Since i did this i allready restarted the was several times but the group still isn't found.

      I try to use the group for sap logon and i need it for my model in web dynpro. because metadata only can be retrieve with a group.

      I already tried several names : PUBLIC, TEST, ...

      I also checked the table RZLLITAB and the mapping is present there.

      Do i need to configure the group or the assignment or something like that? Maybe something goes wrong there?



  • avatar image
    Former Member
    Feb 06, 2006 at 02:38 PM


    We had the same problem one year ago.

    After looking for a lot, we found Notes that resolved the problem.

    See Note OSS 164937, 23617, 32188

    I hope it helps



    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Feb 06, 2006 at 03:57 PM


    I have the same problem. In SMLG click the icon looks like the server and then double click the Favourite 'something', I forgot the exact name. Here you define the PUBLIC logon group as well. I'm not familiar with the data that what must be filled in... but I put the IP address of the server and 3600 as the Service.

    Now this will list your logon group in the SAP Logon pad if you click the Groups. The problem that i'm having is when I choose Add and Logon, I can logon properly, but the next time i logon, it complains that the connection to partner broken.

    I will try to look at the notes listed above and hopefullt it will solve my problem im having. You can also look at the update of my problem in the other thread called JCo connection problem.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Feb 11, 2006 at 10:59 PM


    i think i have the same problem. I installed the NSP ABAP preview on the same system i run a NW2004s Workplace (JAVA). Now i just want to have an JCO-Connection to the NSP System. The JCO-Connection works for an connection to a Application server. But for a WD it must be a connection to a logongroup so i just create a simple logon group with one aplication server for my NSD.

    - In the Transaktion SMLG the logongroup is created.

    Logon Group Instance

    PUBLIC blaueelise_NSP_02

    - in the SAP - Logon i can not reach the logon group.

    - Also with lgst i get the message

    group PUBLIC not found.

    in the service file there is an entry:

    sapmsnsp 3602/tcp

    SID = NSP instance = 02

    So the simple question is how to create an logon group in the System?

    The i think my primary problem (the JCO-Connection) will be solved.

    Thank for your hepl


    Message was edited by: Kipp Michael

    Hello i just found this weblog:


    This could match to our problem.


    Add comment
    10|10000 characters needed characters exceeded