Skip to Content
avatar image
Former Member

External Webdispatcher with SAP HANA SPS09 MDC issue

hello,

I am in progress to configure/install Fiori on my landscape, and I am facing issue in the configuration.

Here is my landscape :

Webdispatcher (WDP)

Host : gwhost.test-mdc.com

inst N° : 02

HTTP Listen port : 8102

HTTPS Listen port : 4302

SAP NetWeaver Gateway (GWC)

Host: gwhost.test-mdc.com

inst N°: 00

HTTP Listen port : 8000

SAP ERP 6.0 EHP7 (ERP)

Host: erphost.test-mdc.com

Inst N° : 00

HTTP Listen port : 8000

HANA SPS09 MDC (SR4)

Host: hanahost.test-mdc.com and hanahost-sr4.test-mdc.com (alias for the SR4 tenant)

With a Tenant DB : SR4

The internal WebDispatcher is listening on port 8000.

I have done the configuration of HTTP Access to Multitenant DB. My webdispatcher.ini profile section look like this :

wdisp/enable_admin_ui_for_sid = SYS

wdisp/system_0 = SID=SYS, EXTSRV=http://localhost:3$(SAPSYSTEM)14, SRCVHOST=hanahost.test-mdc.com

wdisp/system_1 = SID=SR4, EXTSRV=http://localhost:3$(SAPSYSTEM)42, SRCVHOST=hanahost-sr4.test-mdc.com

I have check the access to both xs engine directly in a browser by using the /sap/hana/ide on both system and it works fine:

http://hanahost.test-mdc.com:8000/sap/hana/ide

http://hanahost-sr4.test-mdc.com:8000/sap/hana/ide

So I conclude that the HTTP configuration in HANA is Correct.

So I continue by configuring the External Web Dispatcher :

Here is my configuration (profile)

icm/server_port_0 = PROT=HTTP,HOST= gwhost,PORT=81$$

icm/server_port_1 = PROT=HTTP,HOST=localhost,PORT=81$$

#-----------------------------------------------------------------------

# Backend System

#-----------------------------------------------------------------------

wdisp/system_0 = SID=GWC, NR=00, MSHOST= gwhost.test-mdc.com, MSPORT=8101, SRCSRV=*:*, SRCURL=/sap/opu/odata, SSL_ENCRYPT=0

wdisp/system_1 = SID=ERP, NR=00, MSHOST= erphost.test-mdc.com, MSPORT=8101, SRCSRV=*:*, SRCURL=/sap/public/bc/;/sap/bc/, SSL_ENCRYPT=0

#-----------------------------------------------------------------------

# Hana System

#-----------------------------------------------------------------------

wdisp/system_2 = SID=SR4, XSSRV=http://hanahost.test-mdc.com:8000, SRCSRV=*:*, SRCURL=/sap/hba/;/sap/hana, SSL_ENCRYPT=0

wdisp/system_conflict_resolution = 1

icm/HTTPS/verify_client = 0

I have restarted the external Webdispatcher and do some test :

Access the ERP system through the Webdispatcher by using the url :

http://gwhost.test-mdc.com:8102/sap/bc/ping?sap-client=100&sap-language=EN

=> Works Fine

Access the GWC system through the Webdispatcher by using the url:

http://gwhost.test-mdc.com:8102/sap/opu/odata/iwfnd/catalogservice/?sap-client=001

=> Works Fine

Access the HANA System through the Webdispatcher by using the url

http://gwhost.test-mdc.com:8102/sap/hana/ide

=> Get 503 Service Not Available. !!!!!

Here is my logs :

In the logs of External Web dispatcher (WDP) I have a lot of :

IcrIHandleHTTPClientRequest: dest=' hanahost.test-mdc.com:8000' URL='/sap/hana/xs/internal/topology.xscfunc' -> -1

[Thr 1732] Could not connect to (any) XS Engine at hanahost.test-mdc.com. URL=/sap/hana/xs/internal/topology.xscfunc

[Thr 1732] rc=-1, HTTP response code: 503

[Thr 1732] *** ERROR => Could not get server list with path /sap/hana/xs/internal/topology.xscfunc [icrxx.c      7388]

HTTP request (raw) [2/12/1]:

[Thr 3400]   GET /sap/hana/ide HTTP/1.1

[Thr 3400]   host: gwhost.test-mdc.com:8102

[Thr 3400]   connection: keep-alive

[Thr 3400]   accept: text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,*/*;q=0.8

[Thr 3400]   user-agent: Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/42.0.2311.135 Safari/537.36

[Thr 3400]   accept-encoding: gzip, deflate, sdch

[Thr 3400]   accept-language: fr-FR,fr;q=0.8,en-US;q=0.6,en;q=0.4

[Thr 3400]   cookie: sap-usercontext=sap-client=001; MYSAPSSO2=XXX; SAP_SESSIONID_GWC_001=XXX;

[Thr 3400] Connection Info: role=Server, local=gwhost:8102, peer=192.168.211.196, protocol=HTTP

[Thr 3400] HttpPortTableMatchPort: Port 0, *:* (:::0) matches request

[Thr 3400] HttpPortTableMatchPort: Port 1, *:* (:::0) matches request

[Thr 3400] HttpPortTableMatchPort: Port 2, *:* (:::0) matches request

[Thr 3400] IcrFindTargetSystem: SR4 found for addr: 192.168.63.59:8102 url: /sap/hana/ide

[Thr 3400] Wed May 06 12:40:05 2015

[Thr 3400] HttpGetRouteTargetSystem: SID='SR4'

[Thr 3400] HttpSrvHdlRequest: method: 1; path: /sap/hana/ide

[Thr 3400] Handler 0: HttpAuthHandler matches url: /sap/hana/ide

[Thr 3400] Handler 1: HttpModHandler matches url: /sap/hana/ide

[Thr 3400] Handler 3: HttpWebDispHandler matches url: /sap/hana/ide

….

HTR: stateless request (no valid session ID found) or initial request for stored session id

[Thr 3400] ICR: IcrAttachToServer('!DIAG' 1 2 4 0 port:-/-1/-1) -1-> 13

[Thr 3400] *** ERROR => no valid HTTP destination server available for system 'SR4' rc=13 {0002000c} [http_route.c 3672]

[Thr 3400] ICR: IcrAttachToServer('!DIAG' 1 2 4 0 port:-/-1/-1) -1-> 13

[Thr 3400] IcmCalcNextSchedule: next schedule in 0 secs (1430908805)

[Thr 3400] NiWakeupExec: send wakeup signal to 60919->64991 (sock 32784)

[Thr 3400] HTR: HtrCleanupConnection -> 0

[Thr 3400] HttpSrvHdlRequest: Error return: 701

[Thr 3400] IcmPlCheckRetVal: Plugin retval: PLUGIN_RET_ERROR (701)

[Thr 3400] IcmHandleNetRead(id=2/12): read_len: 1008, HandleNetData returned: 701

[Thr 3400] IcmHandleNetRead(id=2/12): PlugInHandleNetData failed (rc=701)

On the internal Webdispatcher of HANA :

I have a lot of occurrence like that :

CONNECTION (id=4/326):

    used: 1, type: default, role: Server(1), stateful: 0

    NI_HDL: 121, protocol: HTTP(1)

    local host: 192.168.61.207:8000 ()

    remote host: 192.168.63.59:63100 ()

    status: NOP

    connect time: 06.05.2015 12:44:43

    MPI request:        <0>      MPI response:        <0>     MPI next: <0>  

    request_buf_size:   0 response_buf_size:   0    

    request_buf_used:   0 response_buf_used:   0    

    request_buf_offset: 0        response_buf_offset: 0    

[Thr 139794739345152] MPI:8 create pipe 0x7f2486398fa0 1

[Thr 139794739345152] MPI<28a>8#1 Open( ANONYMOUS 8 1 ) -> 8

[Thr 139794739345152] MPI<28a>8#2 Open( ANONYMOUS 8 0 ) -> 8

[Thr 139794739345152] Wed May  6 12:44:43 2015

[Thr 139794739345152] MPI:9 create pipe 0x7f2486399168 1

[Thr 139794739345152] MPI<28b>9#1 Open( ANONYMOUS 9 0 ) -> 9

[Thr 139794739345152] MPI<28b>9#2 Open( ANONYMOUS 9 1 ) -> 9

[Thr 139794739345152] IcmPlCheckRetVal: Next status: READ_REQUEST(1)

[Thr 139794739345152] IcmReadFromConn(id=4/326): request new MPI (0/0)

[Thr 139794739345152] IcmLowOnBlocks: mpi buffer space free (cur/limit/unreserved): 0/1522/1903)

[Thr 139794739345152] MPI<28a>8#3 GetOutbuf 0 1fd768 65536 (0) -> 0x7f2486595788 44564480 MPI_OK

[Thr 139794739345152] NiIRead: hdl 121 received data (rcd=55,pac=1,RAW_IO)

[Thr 139794739345152] NiIRead: hdl 121 recv would block (errno=EAGAIN)

[Thr 139794739345152] NiIRead: raw read for hdl 121 timed out (0ms)

[Thr 139794739345152] IcmReadFromConn(id=4/326): read 55 bytes, 1 readops (timeout 0)

[Thr 139794739345152] Address   Offset  IcmReadFromConn received

[Thr 139794739345152] ------------------------------------------------------------------------

[Thr 139794739345152] 0x7f24865957d0  000000  47455420 2f736170 2f68616e 612f7873 |GET /sap/hana/xs|

[Thr 139794739345152] 0x7f24865957e0  000016  2f696e74 65726e61 6c2f746f 706f6c6f |/internal/topolo|

[Thr 139794739345152] 0x7f24865957f0  000032  67792e78 73636675 6e632048 5454502f |gy.xscfunc HTTP/|

[Thr 139794739345152] 0x7f2486595800  000048  312e300d 0a0d0a                     |1.0....         |

[Thr 139794739345152] ------------------------------------------------------------------------

[Thr 139794739345152] HttpPlugInHandleNetData(rqid=4/326/1): role: Server(1), status: 1

[Thr 139794739345152] content-length: 0/0, buf_len: 55, buf_offset: 0, buf_status: 0

[Thr 139794739345152] ICT: IctIHttpOpenMessage: 0x7f2520320000 typ=1

[Thr 139794739345152] HttpParseRequestHeader: no content length set

[Thr 139794739345152] HttpParseRequestHeader: no transfer-encoding set

[Thr 139794739345152] HttpParseRequestHeader: no connection value set

[Thr 139794739345152] HttpParseRequestHeader: Version: 1000

[Thr 139794739345152] HttpParseRequestHeader: Keep-Alive: 0

[Thr 139794739345152] HttpParseRequestHeader: no server port set

[Thr 139794739345152] HTTP request (raw) [4/326/1]:

[Thr 139794739345152]   GET /sap/hana/xs/internal/topology.xscfunc HTTP/1.0

[Thr 139794739345152] Connection Info: role=Server, local=hanahost.test-mdc.com:8000, peer=192.168.63.59, protocol=HTTP

[Thr 139794739345152] IcrMatchStaticVhosts: system SYS does not match to host header: :80

[Thr 139794739345152] IcrMatchStaticVhosts: system SR4 does not match to host header: :80

[Thr 139794739345152] IcrFindTargetSystem: No system found for

[Thr 139794739345152] HttpSrvHdlRequest: method: 1; path: /sap/hana/xs/internal/topology.xscfunc

[Thr 139794739345152] Handler 0: HttpAuthHandler matches url: /sap/hana/xs/internal/topology.xscfunc

[Thr 139794739345152] Handler 2: HttpModHandler matches url: /sap/hana/xs/internal/topology.xscfunc

[Thr 139794739345152] Handler 4: HttpWebDispHandler matches url: /sap/hana/xs/internal/topology.xscfunc

[Thr 139794739345152] HttpSubHandlerMatch: add reference to table 0x7f2520bac180, now 2 references, 1 tables used

It seems that the WDP system could not connect correctly to the SR4 System and I don’t know Why ?


Also Someting strange  I have try this in my browser :

http://hanahost.test-mdc.com:8000/sap/hana/xs/internal/topology.xscfunc and I get an answer :

version 1.0

591E96119282E14FBAE766F6E9C02A9F

HTTP hanahost.test-mdc.com 8000 LB=1

HTTPS hanahost.test-mdc.com 4300 LB=1

I have tried to change the configuration of the WDP System by changing the line :

wdisp/system_2 = SID=SR4, XSSRV=http://hanahost.test-mdc.com:8000, SRCSRV=*:*, SRCURL=/sap/hba/;/sap/hana, SSL_ENCRYPT=0

to

wdisp/system_2 = SID=SR4, EXTSRV=http://hanahost.test-mdc.com:8000, SRCSRV=*:*, SRCURL=/sap/hba/;/sap/hana, SSL_ENCRYPT=0


Then I have restarted the WDP System and do another test :

http://gwhost.test-mdc.com:8102/sap/hana/xs/lm


=> Still 503 Error message, but Now in the logs :

in WDP :

no more error :

HTR: forwarding buffer to server (374)

[Thr 4108] Address   Offset  Send to AppServer via net:

[Thr 4108] ------------------------------------------------------------------------

[Thr 4108] GET /sap/hana/xs/lm HTTP/1.1..host: gwhost.test-mdc.com:8102..user-agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:37.0)|

[Thr 4108]  Gecko/20100101 Firefox/37.0..accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*|

[Thr 4108] ;q=0.8..accept-language: fr,fr-FR;q=0.8,en-US;q=0.5,en;q=0.3..accept-encoding: gzip, deflate..dnt: 1..connection:|

[Thr 4108]  keep-alive..clientprotocol: http....

[Thr 4108] ------------------------------------------------------------------------

[Thr 4108] NiIWrite: hdl 89 sent data (wrt=374,pac=1,RAW_IO)

[Thr 4108] IcmPlFlushBuf: NiRawWrite (374 bytes) wrote 374, rc=0

[Thr 4108] MPI<2>0#6 DiscardOutbuf 0 0 0 1c53a0 0 0 -> 000000000C8753F0 MPI_OK

[Thr 4108] HttpSrvHdlRequest: Subhandler rc=704

[Thr 4108] IcmPlCheckRetVal: Next status: WRITE_RESPONSE(4)

[Thr 4108] IcmHandleNetRead(id=0/11): read_len: 352, HandleNetData returned: 4

[Thr 4108] IcmHandleNetRead(id=0/11): status 1 -> 4

[Thr 4108] IcmReadFromPartner(id=0/11): read with maximum timeout 500

[Thr 4108] IcmReadFromPartner(id=0/11): request new MPI (0/0)

[Thr 4108] IcmLowOnBlocks: mpi buffer space free (cur/limit/unreserved): 0/716/896)

[Thr 4108] MPI<3>1#3 GetOutbuf -1 1c53a0 65536 (0) -> 000000000C875410 20971520 MPI_OK

[Thr 4108] NiIRead: hdl 89 recv would block (errno=EAGAIN)

[Thr 4108] NiIPeek: peek successful for hdl 89 (r)

[Thr 4108] NiIRead: hdl 89 received data (rcd=357,pac=1,RAW_IO)

[Thr 4108] NiIRead: SiRecv failed for hdl 89/sock 32704

[Thr 4108]     (SI_ECONN_BROKEN/0; I4; ST; P=192.168.61.207:8000; L=192.168.63.59:64767)

[Thr 4108] IcmReadFromPartner(id=0/11): connection broken (len=0,357)

[Thr 4108] ConnPoolCloseNiHdl:

[Thr 4108]    Pool Entry: 00000000082AFB60:

[Thr 4108] Wed May 06 13:31:45 2015

[Thr 4108]    NI: 89, SSL: 0000000000000000, allocated: 1, inuse: 1, desc: 0000000002B15130

[Thr 4108] NiICloseHandle: shutdown and close hdl 89/sock 32704

[Thr 4108] Address   Offset  IcmReadFromPartner received

[Thr 4108] ------------------------------------------------------------------------

[Thr 4108] HTTP/1.0 503 Service Unavailable..date: Wed, 06 May 2015 11:30:33 GMT..pragma: no-cache|

[Thr 4108] ..connection: close..content-length: 160    ..content-type: text/html..x-sap-icm-err-id: |

[Thr 4108] ICMENOSYSTEMFOUND....<html><head><title>Application Server Error|

[Thr 4108] </title></head><body>..<H2><b>503 Service not available</b></H2>|

[Thr 4108] <br>..<hr>Wed May  6 13:30:33 2015...</body></html>..           |

[Thr 4108] ------------------------------------------------------------------------

and In the Internal HANA Webdispatcher I Have :

[Thr 139796962248448] CONNECTION (id=1/86):

    used: 1, type: default, role: Server(1), stateful: 0

    NI_HDL: 97, protocol: HTTP(1)

    local host:  192.168.61.207:8000 ()

    remote host: 192.168.63.59:64767 ()

    status: READ_REQUEST

    connect time: 06.05.2015 13:30:17

    MPI request:        <aa>     MPI response:        <ab>    MPI next: <0>  

    request_buf_size:   0        response_buf_size:   0    

    request_buf_used:   0        response_buf_used:   0    

    request_buf_offset: 0        response_buf_offset: 0    

[Thr 139796962248448] IcmReadFromConn(id=1/86): request new MPI (0/0)

[Thr 139796962248448] IcmLowOnBlocks: mpi buffer space free (cur/limit/unreserved): 0/1522/1903)

[Thr 139796962248448] MPI<aa>2#5 GetOutbuf 0 1cd6c0 65536 (0) -> 0x7f2512cd26e0 44564480 MPI_OK

[Thr 139796962248448] NiIRead: hdl 97 received data (rcd=374,pac=1,RAW_IO)

[Thr 139796962248448] NiIRead: hdl 97 recv would block (errno=EAGAIN)

[Thr 139796962248448] NiIRead: raw read for hdl 97 timed out (0ms)

[Thr 139796962248448] IcmReadFromConn(id=1/86): read 374 bytes, 1 readops (timeout 0)

[Thr 139796962248448] Address   Offset  IcmReadFromConn received

[Thr 139796962248448] ------------------------------------------------------------------------

[Thr 139796962248448] GET /sap/hana/xs/lm HTTP/1.1..host: gwhost.test-mdc.com:8102..user-agent: Mozilla/5.0|

[Thr 139796962248448]  (Windows NT 6.3; WOW64; rv:37.0) Gecko/20100101 Firefox/37.0..accept: text/html|

[Thr 139796962248448] ,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8..accept-language: fr,fr-F|

[Thr 139796962248448] ------------------------------------------------------------------------

[Thr 139796962248448] HttpPlugInHandleNetData(rqid=1/86/1): role: Server(1), status: 1

[Thr 139796962248448] content-length: 0/0, buf_len: 374, buf_offset: 0, buf_status: 0

[Thr 139796962248448] ICT: IctIHttpOpenMessage: 0x7f24eabf6000 typ=1

[Thr 139796962248448] HttpParseRequestHeader: no content length set

[Thr 139796962248448] HttpParseRequestHeader: no transfer-encoding set

[Thr 139796962248448] HttpParseRequestHeader: Version: 1001

[Thr 139796962248448] HttpParseRequestHeader: Keep-Alive: 1

[Thr 139796962248448] HTTP request (raw) [1/86/1]:

[Thr 139796962248448]   GET /sap/hana/xs/lm HTTP/1.1

[Thr 139796962248448]   host: gwhost.test-mdc.com:8102

[Thr 139796962248448]   user-agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:37.0) Gecko/20100101 Firefox/37.0

[Thr 139796962248448]   accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8

[Thr 139796962248448]   accept-language: fr,fr-FR;q=0.8,en-US;q=0.5,en;q=0.3

[Thr 139796962248448]   accept-encoding: gzip, deflate

[Thr 139796962248448]   dnt: 1

[Thr 139796962248448]   connection: keep-alive

[Thr 139796962248448]   clientprotocol: http

[Thr 139796962248448] Connection Info: role=Server, local=hanahost.test-mdc.com:8000, peer=192.168.63.59, protocol=HTTP

[Thr 139796962248448] Wed May  6 13:30:33 2015

[Thr 139796962248448] IcrMatchStaticVhosts: system SYS does not match to host header: gwhost.test-mdc.com:8102

[Thr 139796962248448] IcrMatchStaticVhosts: system SR4 does not match to host header: gwhost.test-mdc.com:8102

[Thr 139796962248448] IcrFindTargetSystem: No system found for

[Thr 139796962248448] HttpSrvHdlRequest: method: 1; path: /sap/hana/xs/lm

[Thr 139796962248448] Handler 0: HttpAuthHandler matches url: /sap/hana/xs/lm

[Thr 139796962248448] Handler 2: HttpModHandler matches url: /sap/hana/xs/lm

[Thr 139796962248448] Handler 4: HttpWebDispHandler matches url: /sap/hana/xs/lm

[Thr 139796962248448] HttpSubHandlerMatch: add reference to table 0x7f250cf3d180, now 2 references, 1 tables used

[Thr 139796962248448] HttpSubHandlerCall: Call Handler: HttpAuthHandler (0x7f250cf1e180/0x7f250cf3d180), task=TASK_REQUEST(1), header_len=374

[Thr 139796962248448] >> start >> CsiGetInstance(0x7f250ce6d2e0)

[Thr 139796962248448] << end   << CsiGetInstance(0x7f250ce6d2e0) returned inst=0x7f250ce2da00

[Thr 139796962248448] >> start >> CsiExecute(0x7f250ce2da00,0x7f2504461820,15,1,0x7f2504463920,0x7f250446394c,0)

[Thr 139796962248448] >> VsaScan(0x7f250ce8e6e0,0x7f250cedf680,0x7f250cf309c0,0x7f250ceb4530,NULL) >>

[Thr 139796962248448] << VsaScan(0x7f250ce8e6e0,0x7f250cedf680,0x7f250cf309c0,0x7f250ceb4530,NULL) = 0 <<

[Thr 139796962248448] << end   << CsiExecute(CSI_RC==VSI_OK)

[Thr 139796962248448] >> start >> CsiFreeInstance(0x7f250ce2da00)

[Thr 139796962248448] << end   << CsiFreeInstance(CSI_RC==VSI_OK)

[Thr 139796962248448] HttpSubHandlerItDeactivate: handler 0: HttpAuthHandler

[Thr 139796962248448] HttpSubHandlerCall: Call Handler: HttpModHandler (0x7f250cf1df80/0x7f250cf3d180), task=TASK_REQUEST(1), header_len=374

[Thr 139796962248448] HttpModGetDefRules: determined the defactions: COMPAT_HANDLING  (144)

[Thr 139796962248448] HttpModHandler: webdisp: add x-forwarded-for: hanahost.test-mdc.com

[Thr 139796962248448] HttpModHandler: clientprotocol exists

[Thr 139796962248448] IcrMatchStaticVhosts: system SYS does not match to host header: gwhost.test-mdc.com:8102

[Thr 139796962248448] IcrMatchStaticVhosts: system SR4 does not match to host header: gwhost.test-mdc.com:8102

[Thr 139796962248448] IcrFindTargetSystem: No system found for

[Thr 139796962248448] IcrMatchStaticVhosts: system SYS does not match to host header: gwhost.test-mdc.com:8102

[Thr 139796962248448] IcrMatchStaticVhosts: system SR4 does not match to host header: gwhost.test-mdc.com:8102

[Thr 139796962248448] IcrFindTargetSystem: No system found for

[Thr 139796962248448] IcrMatchStaticVhosts: system SYS does not match to host header: gwhost.test-mdc.com:8102

[Thr 139796962248448] IcrMatchStaticVhosts: system SR4 does not match to host header: gwhost.test-mdc.com:8102

[Thr 139796962248448] IcrFindTargetSystem: No system found for

[Thr 139796962248448] NiHLGetNodeAddr: got hostname 'gwhost.test-mdc.com' from operating system

[Thr 139796962248448] NiIGetNodeAddr: hostname 'gwhost.test-mdc.com' = addr 192.168.63.59

[Thr 139796962248448] HttpModHandler: x-sap-webdisp-ap header added: http=8102,https=4300

[Thr 139796962248448] HttpModHandler: perform the actions: COMPAT_HANDLING  (144)

[Thr 139796962248448] MPI<aa>2#6 GetOutbuf -1 1bd688 65536 (0) -> 0x7f2512cc26a8 44564480 MPI_OK

[Thr 139796962248448] HttpModHandler: serialize new http header

[Thr 139796962248448] ICT: IctHttpCloseMessage( 0x7f24eabf6000 ) -> u=0 rc=0

[Thr 139796962248448] ICT: IctIHttpOpenMessage: 0x7f24eabf9000 typ=1

[Thr 139796962248448] Address   Offset  request header rewritten (1 block):

[Thr 139796962248448] ------------------------------------------------------------------------

[Thr 139796962248448] GET /sap/hana/xs/lm HTTP/1.1..host: gwhost.test-mdc.com:8102..user-agent: Mozilla/5.0|

[Thr 139796962248448]  (Windows NT 6.3; WOW64; rv:37.0) Gecko/20100101 Firefox/37.0..accept: text/html|

[Thr 139796962248448] ,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8..accept-language: fr,fr-FR|

[Thr 139796962248448] ;q=0.8,en-US;q=0.5,en;q=0.3..accept-encoding: gzip, deflate..dnt: 1..connection|

[Thr 139796962248448] : keep-alive..clientprotocol: http..x-forwarded-for: 192.168.63.59..x-sap-webdisp-ap: http=8102,https=4300....  |

[Thr 139796962248448] ------------------------------------------------------------------------

[Thr 139796962248448] MPI<aa>2#7 DiscardOutbuf 0 0 0 1bd688 0 0 -> 0x7f2512cc2688 MPI_OK

[Thr 139796962248448] HTTP request (rewritten) [1/86/1]:

[Thr 139796962248448]   GET /sap/hana/xs/lm HTTP/1.1

[Thr 139796962248448]   host: gwhost.test-mdc.com:8102

[Thr 139796962248448]   user-agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:37.0) Gecko/20100101 Firefox/37.0

[Thr 139796962248448]   accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8

[Thr 139796962248448]   accept-language: fr,fr-FR;q=0.8,en-US;q=0.5,en;q=0.3

[Thr 139796962248448]   accept-encoding: gzip, deflate

[Thr 139796962248448]   dnt: 1

[Thr 139796962248448]   connection: keep-alive

[Thr 139796962248448]   clientprotocol: http

[Thr 139796962248448]   x-forwarded-for: 192.168.63.59

[Thr 139796962248448]   x-sap-webdisp-ap: http=8102,https=4300

[Thr 139796962248448] Wed May  6 13:30:33 2015

[Thr 139796962248448] HttpSubHandlerItDeactivate: handler 1: HttpModHandler

[Thr 139796962248448] HttpSubHandlerCall: Call Handler: HttpWebDispHandler (0x7f250cf1e200/0x7f250cf3d180), task=TASK_REQUEST(1), header_len=446

[Thr 139796962248448] HttpRouteHandler: 1 446 0x7f250cf1e200 (nil)

[Thr 139796962248448] HTR: allow pooled connection reuse for new connection

[Thr 139796962248448] HTR: creating new connection 0x7f250cc7a030

[Thr 139796962248448] HTR: HTTP version = 1001.

[Thr 139796962248448] HTR: connection = 'keep-alive'

[Thr 139796962248448] IcrMatchStaticVhosts: system SYS does not match to host header: gwhost.test-mdc.com:8102

[Thr 139796962248448] IcrMatchStaticVhosts: system SR4 does not match to host header: gwhost.test-mdc.com:8102

[Thr 139796962248448] IcrFindTargetSystem: No system found for

[Thr 139796962248448] HTR: HtrCleanupConnection -> 0

[Thr 139796962248448] HttpSrvHdlRequest: Error return: 701

[Thr 139796962248448] IcmPlCheckRetVal: Plugin retval: PLUGIN_RET_ERROR (701)

[Thr 139796962248448] IcmHandleNetRead(id=1/86): read_len: 374, HandleNetData returned: 701

[Thr 139796962248448] MPI<aa>2#8 Cancel 7 -> MPI_OK

[Thr 139796962248448] MPI<ab>3#3 Cancel 7 -> MPI_OK

[Thr 139796962248448] PlugInStopConn: role: Server(1), error: -51, write_err: 1

[Thr 139796962248448] PlugInStopConn: write error response

[Thr 139796962248448] HttpPlugInWriteErrorText: return static error for "No system found" (-51)

[Thr 139796962248448] HttpPlugInWriteErrorText: templ_path: /usr/sap/SR4/HDB00/hanahost/data/icmandir/error_templ, err_idx: -1

[Thr 139796962248448] ICT: IctIHttpOpenMessage: 0x7f24eabed000 typ=2

[Thr 139796962248448] HttpParseResponseHeader: no transfer-encoding set

[Thr 139796962248448] HttpParseResponseHeader: Version: 1000

[Thr 139796962248448] HttpParseResponseHeader: Keep-Alive: 0

[Thr 139796962248448] HTTP response  [1/86/1]:

[Thr 139796962248448]   HTTP/1.0 503 Service Unavailable

[Thr 139796962248448]   date: Wed, 06 May 2015 11:30:33 GMT

[Thr 139796962248448]   pragma: no-cache

[Thr 139796962248448]   connection: close

[Thr 139796962248448]   content-length: 160

[Thr 139796962248448]   content-type: text/html

[Thr 139796962248448]   x-sap-icm-err-id: ICMENOSYSTEMFOUND



I am lost… if someone could help me.


Best Regards

Guillaume Bruyneel

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • avatar image
    Former Member
    May 06, 2015 at 09:02 PM

    hello,

    I have made some tests, after few investigations...

    When I use the :

    wdisp/system_2 with the EXTSRV and when I had the following redirection :

    icm/HTTP/redirect_0 = PREFIX=/,FROM=/sap/hana/*,FOR=gwhost.test-mdc.com,HOST=hanahost-sr4.test-mdc.com,PORT=8000

    then in this case I can do in my browser :

    http://gwhost.test-mdc.com:8102/sap/hana/xs/lm => I reach the HANA XS

    and I am sure that this is the SR4 tenant XS as If I test the url /sap/hana/xs/ide I can only log with a user of the SR4 tenant !!

    That seems to solve my little issue, but I still do not understand....

    If someone have an idea ?

    Best Regards...

    Guillaume

    Add comment
    10|10000 characters needed characters exceeded

  • Nov 20, 2015 at 11:30 PM

    Hi Guillaume,

    I know this post is a bit old, but have you been able to figure it out? I am facing the same issue, and just cannot find a solution for it. I am running SP10 Rev. 102, but apart from that, configuration and error messages are exactly the same (either using XSSRV and EXTSRV).

    Any help would be much appreciated!

    Marco

    Add comment
    10|10000 characters needed characters exceeded