Skip to Content
author's profile photo Former Member
Former Member

BO 4.1 SP5 Web Intelligence: No limits set - but only getting partial results

Hello,

I'm using a WebI report with a query which should return round about 12.000 rows, but I only get exact 10.000 rows as resultset.

These steps I already tried:

  • IDT -> Query Options -> Disabled Limit size of result set and Limit execution time
  • Report Query Panel -> Query Properties -> Disabled Max rows retrieved and Max retrieval time
  • Restarted Web Intelligence Processing Server

But I'm still getting only partial results. I don't know what else I could try. Any suggestions?

System:

BusinessObjects 4.1 SP5

Web Intelligence (Browser with Java Applet) and Web Intelligence Rich Client

Add a comment
10|10000 characters needed characters exceeded

Related questions

6 Answers

  • Posted on Apr 30, 2015 at 12:38 PM

    Hi Marc,

    Might be because your values are getting aggregated. Did you check the Avoid duplicate row aggregation ?

    Right click on table > format table > check the avoid duplicate row aggregation, which will be unchecked by default.


    Capture.JPG (21.1 kB)
    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Tanveer,

      I checked the Avoid duplicate row aggregation but I'm still getting partial results.

      The former system was BO 3.1, where the same problem existed. But in BO 3.1 I only had to disable Limit size of result set and Limit execution time in the UDT and everything worked fine.

      Since we use BO 4.1 it's not possible for me to fix this problem.

  • author's profile photo Former Member
    Former Member
    Posted on Apr 30, 2015 at 12:38 PM

    Hi,

    Are you gettting data from multisource universe?

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Apr 30, 2015 at 12:55 PM

    Hi,

    May be you are getting aggregated rows in webi.Copy the SQL of query and run the backend and compare the records.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on May 01, 2015 at 09:47 AM

    After changing universe parameters have you exported universe to repository again?

    Can you please check

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on May 01, 2015 at 10:18 AM

    Given that you're getting the error in both, could it be set by the DBA with BO having no control over it?

    The only other option I can think of is some obscure PRM file setting that someone experimented with.

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on May 05, 2015 at 06:54 AM

    Hi Marc ,

    What is your backend databse ? which connection you are using ?

    Did you checked in Connection parameters ?Check connection pool mode is set to disconnect after each transaction !

    Add a comment
    10|10000 characters needed characters exceeded

      1. From your 3.1 environment promote(using UMT) the web-I report, connection and the universe to 4.1 as is and check what results you get in 4.1 when you refresh the report.
      2. open the web-I report, copy the SQL and execute it directly on the database(using Toad like) tool. While logging on to the database, use the same credential that you use to refresh the report.


      Regards,

      Naras

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.