Skip to Content
author's profile photo Former Member
Former Member

Password file required for commandline job execution?

Hi all,

It appears that I am unable to execute batch jobs through the commandline without using the password file option.

I have correctly generate the execution script files through the Data Services Management Console. I have reviewed the scripts and they all appear well formed with the correct parameters.

But when I generate the script and unselect the "Use Password File" option, I keep getting this error when trying to launch the job from the commandline:

(14.2.4.668) 04_24_2015 09:54:58 (7696): No DS Local Repositories Registred in CMS

(14.2.4.668) 04_24_2015 09:54:58 (7696): *** RWJL_EXIT called.

(14.2.4.668) 04_24_2015 09:54:58 (7696): *** ERROR: RWJobLauncher failed to connect to CMS. (BODI-1250220) [/code]

When I tick the "Use Password File" option - it all works fine. However, I have a need to use the "old style" approach where there was no such thing as a password file.

So the above errors happens on our SAP DS 4.2 SP4 test system that runs on Microsoft Windows and uses SQL Server 2012 as repository + CMS (IPS) database.

When I try this on the actual SAP DS 4.2 SP4 system that runs on Red Hat Linux Enterprise and uses Oracle 11gR2 as repository + CMS (IPS) database, I get this error:

04-17-2015 14:22:51 Specified CMS authentication is not available.

04-17-2015 14:22:51 ERROR(CCMSLogonManager::InitializeSession)

04-17-2015 14:22:51 RWJobLauncher failed to connect to CMS.

04-17-2015 14:22:51 RWJobLauncher return code: 180011

On our older versions of Data Integrator (down to 11.5.3) the commandline execution on both Windows and Linux always worked fine and never required the use for a password file (I don't think this option even existed back then).

I have a requirement to make this work WITHOUT the password file. I have consulted the technical manuals but I cannot find anything that indicates this shouldn't work. I also cannot find any SAP Note that indicates that there is a problem here.

Am I missing something here? Has anyone else ran into the same issue and errors - and if so, could you please share how you resolved this? At this stage, my next port of call is to raise a SAP Support incident but I want to make sure I have tried all options first before I reach out to support.

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

2 Answers

  • Posted on Apr 23, 2015 at 10:38 PM

    User authentication (also for connecting to DS Designer) has been introduced in DS 4.0.

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      the CMS connection information that you see in the exported or scheduled command line is taken from the settings that you do in the CMS Connection link in the DS MC under Administrator -> Management, not from the user that you use for login to DS MC

      by default that will be secEnterprise

      update that connection and recreate the script and check if that works

  • Posted on Jul 25, 2016 at 10:04 AM

    Hi Erik,

    Did you manage to resolve the issue?

    Regards,

    Sunil

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.