Skip to Content
0
Apr 23, 2015 at 03:27 PM

PI 7.4 - interface from ECC(idoc) > JDBC, idoc not making it from sm58 '

365 Views

Hi Experts,

I've got an interface which works in our dev and 2 of our test systems but NOT the 3rd test system. It doesnt work in our live system either. (essentially its a split receiver determination - goes to both jdbc and a file).

I've reintroduced the config from the dev system to the 3rd test system and overwritten its ico/scenario in the hope that it might work - it didnt make any difference as was getting the first error below in bold.

I've checked all RFC connections, destinations, partner profiles and ports, all seem in order and mirror systems that work, bar the naming conventions.

I've checked The FM version, its the same version as the system which works.

In sm58 I was originally getting the error 'Commit fault: ASJ.ejb.005043 (Failed in component:sap.com/com.sap.aii.ad', upon 'googling' this error it was suggested on SCN to essentially delete old config and reimport / rebuild the interface () . I've tried to reimport the config scenario / ico, i then deleted the config scenario and reimported it. This hasnt worked.

I have had our Basis team double check the NWA settings, and the ResourceAdaptor settings were reset.

When re running the trfc in sm58, i now get the error ' Failed to resolve repository reference @XI_IDOC_DE FAULT_DESTINATION_DEV'

Would appreciate some feedback as to what to try next..