Skip to Content
avatar image
Former Member

Team Provider - SAPGUI for Java

Hello everyone,

at the moment I try to use Eclipse with SAPUI5 Plugin on Mac (OS X Yosemite).

For this i installed SAPGUI for Java 7.40 and added a System via Expert Mode. When i now try to share the Project to this System in Eclipse the Details for the Connection are Empty and the Logon Fails.

If i try to Logon via SAPGUI for Java it works. But the Login via Eclipse doesn't.

Are there any Mac Users out there who can help me?

Regards & thank you!

Sascha

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • Apr 22, 2015 at 05:13 AM
    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member
      <?xml version="1.0" encoding="UTF-8"?>
      <Landscape version="1" updated="2015-04-22T18:42:16Z" origin="file:/Users/Sascha/Library/Preferences/SAP/SAPGUILandscape.xml" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="SAPUILandscape.xsd" generator="SAP GUI for Java 7.40 rev 2">
        <Services>
          <Service expert="1" name="Entwicklungssystem" msid="c9125e5c-3847-4932-8c9d-1289d0d369c1" type="SAPGUI" uuid="c7818e5c-3847-4932-8c9d-1289d0d369c1" routerid="e970f412-5735-47d1-bbf9-2e8e10414b1a" server="192.168.1.201:501" mode="1"/>
        </Services>
        <Workspaces default="747e98df-9cde-42cd-a344-5dc05faa3f93">
          <Workspace expanded="1" name="JavaGUI Services" uuid="747e98df-9cde-42cd-a344-5dc05faa3f93" description="JavaGUI Services configuration">
            <Item uuid="6ad94560-1b28-4e6f-9cb2-b8ec07e27019" serviceid="c7818e5c-3847-4932-8c9d-1289d0d369c1"/>
          </Workspace>
        </Workspaces>
        <Messageservers/>
        <Routers>
          <Router router="/H/xxx.xxx.xxx/S/3299" name="Router 3" uuid="e970f412-5735-47d1-bbf9-2e8e10414b1a"/>
        </Routers>
      </Landscape>
      

      This is how my Landscape.xml looks like. Still no Connection possible. =(

  • avatar image
    Former Member
    Apr 27, 2015 at 08:34 PM

    Still struggling with the configuration.

    Found an Error in the Log of Eclipse saying the following:

    Failed to load discovery "/sap/bc/adt/core/discovery" for destination com.sap.ide.ui5.team.ZTEST; using default settings

    &

    Caused by: com.sap.conn.jco.JCoException: (101) JCO_ERROR_CONFIGURATION: Configuration of destination com.sap.ide.ui5.team.ZTEST is incorrect: Parameter backend host ('ashost') is missing

    Anyone has an Idea?

    Thanks for your help!

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Apr 30, 2015 at 10:28 AM

    Ok some Update..

    I tried the following:

    Installing ABAP Development Tools and created there a Project and created a connection to the SAP System manually in Eclipse. This works without any Problem.

    So the Problem is that on UI5 Project Site the Parameter "Application Server" is not filled when trying to deploy something on the backend.

    So has anyone a configured SAPUILandscape.xml file which works for deploying something on the backend?

    It doesn't care if with or without SAPRouter.

    If yes would you please so kindly and share them with me.

    Thanks for your Help and best Regards!

    Sascha

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    May 13, 2016 at 12:34 AM

    Did you find any solutions to this issue?

    Add comment
    10|10000 characters needed characters exceeded