Skip to Content
1
Former Member
Apr 14, 2015 at 10:16 AM

RFC Destination SSL handshake failed

6901 Views

Hello,

I have an issue with a RFC Destination, since the certificate was changed (on server side).

When I press "Connection Test" I get the following message:

SSL handshake with evatr.bff-online.de:443 failed

We have already uploaded the new certificate in transaction STRUST and still getting the same error.

I have noticed that the algorithm changed from SHA-1 to SHA-256.

Therefore I checked the SAPCRYPTOLIB version:

New enough...

Here is the RFC Destination in SM59:

SSL is active and the correct list is selected:

Also HTTPS is enabled in Services in transaction SMICM:

Also I spoke to the guys from the networking and they said that SSLv3 communication isn't blocked and the systems are allowed to connect to the internet. They are sure that the problem is not network related.

I have no clue what to do now.

In the attachments you can find a ICM-Trace, where I tried a "Connection Test".

Thanks in advance.

Best regards

Dennis

Attachments

output.txt.zip (11.7 kB)
4.PNG (33.0 kB)
5.PNG (10.3 kB)
1.PNG (27.2 kB)
2.PNG (10.1 kB)
3.PNG (8.2 kB)