Skip to Content
avatar image
Former Member

Upgrade Fiori 2.0

Hello,

We want to upgrade to Fiori 2.0 and this functionality requires and upgrade of Netweaver frontend server 3.0.

we have a embedded configuration and system version is NW 7.40 patch 12.

How can I upgrade to frontend 3.0 to get Fiori 2.0?

Regards

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Feb 04, 2017 at 05:33 AM

    Sergio,

    I believe you need to upgrade S4 HANA instance to 1610. As of now Fiori 2.0 is only available on 1610 for on premise edition.

    Add comment
    10|10000 characters needed characters exceeded

  • Feb 04, 2017 at 12:53 PM

    Hi Sergio

    Yes you can upgrade to Fiori Frontend Server 3.0 on 7.40

    However you will need to check SP minimums carefully against your landscape & app usage

    You can get full details in this note https://launchpad.support.sap.com/#/notes/2355644

    However embedded mode can be problematic if you need to upgrade your Netweaver SP due to the impact on other modules

    You might want to consider taking the opportunity to switch to hub mode

    NOTE: You do *NOT* need S/4HANA to upgrade to FES 3.0

    Rgds

    Jocelyn

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Jocelyn Dart

      Hello Jocelyn,

      I've select Plan and Install or Maintain an addon and I guess that the software components dependencies were accomplished.

      Thanks

      1.jpg (36.1 kB)
  • Feb 10, 2017 at 05:54 AM

    Ok so you have selected the correct Fiori Frontend Server 3.0 - yes that is the version that supports Fiori 2.0

    You will also need SAP_UI 7.51

    Look closely at the recommendations in case you are asked to update your NetWeaver stack.

    I'd recommend you cross check with the Maintenance and Update Strategy and the Fiori 2.0 Welcome Pack

    Note that there are some restrictions on compatible Fiori apps - you can find the list in Fiori apps released for Fiori Frontend Server 3.0

    There's also some general information on Fiori Frontend Server 3.0

    And minimum installation requirements for SAP_UI 7.51

    From a cursory look it looks to me that on 7.40 SP12 you are ok - however as always the devil is in the detail so please read through the additional information and see what the Maintenance Planner reveals.

    Rgds,

    Jocelyn

    Add comment
    10|10000 characters needed characters exceeded