Skip to Content
author's profile photo Former Member
Former Member

Analysis Office Scheduling is failing for a particular user in BI 4.1 SP5 platform,AO 1.4 SP 10

Analysis Office workbook for Micorsoft office Scheduling is failing for a particular user in BI 4.1 SP5 platform,AO 1.4 SP 10.

user is trying to schedule a workbook developed by Administrator , shceduling is failing.

Scheduling is getting success , only if we add the user to administrator Group in BI 4.1 SP5.

the error thrown is Unexpected exception caught.Reason [java.lanf.IndexOutOfBoundException.

for administrator scheduling's are working fine.

here the user is been provided with Full control on the wrokbook.

note: user developed A-office workbook.SSO with BW 7.4 is working fine. but scheduling is failing. but when i made him administrator, scheduling is success.

Platform Details:

BI 4.1 SP5, Aoffice 1.4 SP10, BW 7.4

Any quick answers..??

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • Best Answer
    Posted on Mar 31, 2015 at 01:03 PM

    Hi Silva,


    Does the issue only occur with a specific workbook? Do you have other AO workbooks that you can schedule?


    In order to check the installation of AO BIP ADD-ON, please follow the steps below (I believe that in your case the installation if fine as you are scheduling as administrator):
    #1 - Go to BOE/CMC (Central Management Console);
    #2 - Go to Servers/Core Services/[SIA_NAME].AdaptiveJobServer;
    #3 - Open "Properties" and check the scheduling services;
    #4 - Verify that there is an entry "Analysis Office Scheduling Service".


    If not, then the installation of the AO Add-On failed.


    If it exists, please confirm that the parameter "Precalculation Server Path" is set. The parameter must be filled with the path to the precalculation executable, for example (please adapt to your installation):

    >> "C:\Program Files (x86)\SAP BusinessObjects\Analysis Precalculation\BiPrecalculation.exe"


    If the issue still persists:


    #1 - Check all the precalculation restrictions on chapter 10.1 of the User Guide;
    #2 - Check the Instance Manager in CMC and inform the error of the failed job;


    If the job is with status failed, please create log files of this failed job.
    Please check if the trace level was set to High under CMC -> Servers -> Core Services -> MySIA.AdaptiveJobServer -> TraceLog Service.
    If Trace Level wasn't High please set it and restart the MySIA.AdaptiveJobServer service.
    Afterwards reschedule the workbook that will fail and attach the log here that I can help you.


    The respective log file can be found in logging folder of the BOE:
    Default path: "C:\Program Files (x86)\SAP BusinessObjects\SAP BusinessObjects Enterprise XI 4.0\logging" and check if there is a document named "Analysis_Precalculation_[JobName]_[InstanceID].log".


    Confirm in Analysis for Office that the SSO between BI platform and BW system is correctly working for these workbooks, following the steps below:

    1) Start Analysis Office and use MS Excel - File - Analysis - Open workbook from BI platform;
    2) Log in to BI platform;
    3) Open the workbook and press Refresh All from the Analysis ribbon;
    4) No login to BW system should be necessary, workbook is refreshed;

    If SSO is not set up properly you will get an additional login dialog at step 4) that prompts for BW system credentials.

    Check the registry for the .NET version installed.
    You will find the relevant information here:
    "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework"
    There will be subfolders for each installed .NET version.
    It is mandatory that .NET v3.x is listed here. It is not sufficient to have .NET 2 and .NET 4 installed.


    Tks,
    Diego Ferrary

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Harald Schuller

      Harald,

      Can you confirm scheduling is working for Administrator group. If yes pls post the scheduling error from log file or the generic error code displayed from the instance manager.

      If scheduling is working fine for Administrator group users, all you have to do is follow the below steps.

      1. Map the user/test user to administrator group alone and test it. if it is getting success, definitely Rights would be one suspect area.

      2. Try giving explicit rights and make sure you un check the Inheritance.

      3.is it for particular workbook or for all the workbooks, test on this point.

      4.Go through what's new or Fixed issues in the Aoffice version you are using.

      If issue got resolved or still present, post your findings here so that it help the community.

      Cheers,

      Siva

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.