Skip to Content
Mar 30, 2015 at 02:32 PM

One solution to error "The application failed to initialize properly(0xc0150002)"



In one client PC suddenly I received the following error when trying to start the application:

"The application failed to initialize properly(0xc0150002)"

The client PC is a Windows 7, 32bit and SAP is in version 8.82 PL10. Up until 3-4 days ago SAP worked just fine and it suddenly failed.

I read some post in the forum which referred to the same error message, yet all mentioned O/S compatibility issues, which were irrelevant to my case.

I tried uninstalling and re-installing SAP numerous times, and I even tried to remove all registry inputs mentioning SAP and all the directories, but again nothing change.

I finally managed to fix the problem only after I uninstalled all the Microsoft Visual C++ redistribution packages, uninstalled SAP software, and then made the SAP re-installation, which installed again the Microsoft Visual C++ 2005.

I have the feeling that all this problem was caused after a Windows Update which probably upgraded the C++ redistribution package.

I am not sure if anyone has faced this in past, but I am sure this post will save some time to some user...