Skip to Content

Missing required parameter: When using a concrete application server, SYSNR needs to be in the set of configuration parameters.

Hi,

I get this Error-Message when I try to connect to my BW with AO 2.0

That's what I've found in a log file but I've no clue where I can set the parameter for SAP.Middleware ....

>> Error entry 2015-03-29 17:11:15.200 [Thread 1 (VSTA_Main)]

SAP.Middleware.Connector.RfcConfigurationException: Missing required parameter: When using a concrete application server, SYSNR needs to be in the set of configuration parameters.

at SAP.Middleware.Connector.RfcDestination.CheckConfiguration()

at SAP.Middleware.Connector.RfcDestinationManager.GetDestination(String destinationName)

>> Error entry 2015-03-29 17:11:15.200 [Thread 1 (VSTA_Main)]

SAP.Middleware.Connector.RfcInvalidParameterException: Invalid destination

at SAP.Middleware.Connector.RfcSessionManager.EndContext(RfcDestination destination)

>> Error entry 2015-03-29 17:11:35.895 [Thread 1 (VSTA_Main)]

SAP.Middleware.Connector.RfcConfigurationException: Missing required parameter: When using a concrete application server, SYSNR needs to be in the set of configuration parameters.

at SAP.Middleware.Connector.RfcDestination.CheckConfiguration()

at SAP.Middleware.Connector.RfcDestinationManager.GetDestination(String destinationName)

>> Error entry 2015-03-29 17:11:35.895 [Thread 1 (VSTA_Main)]

SAP.Middleware.Connector.RfcInvalidParameterException: Invalid destination

at SAP.Middleware.Connector.RfcSessionManager.EndContext(RfcDestination destination)

Thx for any hint!

error.png (23.3 kB)
Add a comment
10|10000 characters needed characters exceeded

Related questions

2 Answers

  • Best Answer
    Posted on Mar 29, 2015 at 04:57 PM

    Hi - right now the Analysis Office 2.0 does not work with the SAP Gui 7.40 - please report this to your ramp-up coach; SAP is aware of this issue

    A work-around is to log on using your BIP OLAP connection

    Tammy

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on May 19, 2015 at 02:39 PM

    Hi Thanks it worked for me as well, however the issue keeps happening and I have to repeat the steps.

    Do we know if there is a more permanent fix for either the GUI 7.4 or Analysis 2.0 ?

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.