Skip to Content
author's profile photo Former Member
Former Member

Name-server importing wrong url?


Dear experts,

I am trying to import a track from NWDI so I can add development components to a software component in the track. The problem I am having is:

I keep getting this error " Syntax of 'nibco.com/nbdc/nibcotst' is not valid : Invalid name: appropriate prefix not found; choose another name or another name server". We haven't had this problem in the past...When I go to CMS->Landscape Configurator and click on display development configuration button I get this configuration:

The url for name-server-url property is correct: http://xxxxxxxx:xxxxx/sld/cimom

But when I import to NWDS the url get's changed:

One NWDS:

Another NWDS:

For some reason it is changing the naming server url on import to http://xxxxxx:xxxxx/sld/name and http://xxxxxxxx:xxxxx/sld. Any help is much appreciated.

Thanks,

Bradley Sorensen

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • Posted on Mar 30, 2015 at 09:11 AM

    Hello Bradley,

    A few hints to resolve the problem:

    Namespace prefixes are not available in NWDS

    and

    #1816503 - NWDS not identifying Vendor/Name Prefix defined in SLD

    Best Regards,

    Peter Tari

    Message was edited by: Ervin Szolke I have corrected the note link.

    Add a comment
    10|10000 characters needed characters exceeded

    • Hi Bradley,

      I did not fully read this conversation, but this is how it works in general.

      1. Name server is changed in SLD.

      2. Track "in CMS' webui -- Landscape Configurator" has to be re-saved in order to have the change reflected there (this is what you have done so far)

      3. NWDS development config has to be re-imported on client side. Otherwise it'll consider the old configuration, since after the first sync it creates a local file called ".confdef" and works from that one.

      So as a hint: if you have no open activities in your devconfig, you can even delete it from your NWDS and import it again that makes sure it uses the updated devconfig .

      There is also an "Update Development Configuration" option in the context menu of the Development Config in your NWDS, but if that would not work give it a try re-importing the development config eventually in a new NWDS workspace.

      I hope this helps.

      Cheers,

      Ervin

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.