Skip to Content
avatar image
Former Member

Datasource Autoload Crystal Report

The datasource for Crystal Report is an SQL or StoredProcedure. When you open the report on Crystal Report Viewer, it appears to load the data before the prompts. There is long lag, because it tries to load big data. Without the prompt, the data is big and takes a long time. Is there a way to switch off? Or, ask for prompt before it tries to load.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

5 Answers

  • Best Answer
    avatar image
    Former Member
    Feb 03, 2017 at 08:02 PM

    Hi,

    I unchecked almost all in Report Options that resolved it.

    Thanks.

    Dennis

    Add comment
    10|10000 characters needed characters exceeded

  • Jan 30, 2017 at 03:48 PM

    Hi Dennis,

    Open the report in the CR Designer > Go to File > uncheck 'save data with report' > save.

    -Abhilash

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jan 30, 2017 at 11:49 PM

    Hi,

    The 'save data with report' is already uncheck. It does not work.

    Dennis

    Add comment
    10|10000 characters needed characters exceeded

  • Jan 31, 2017 at 07:24 PM

    When you say Crystal Reports Viewer are you using the report in a .NET or Java application or the Crystal Report Viewer standalone application?

    Any subreports in it?

    Do you have any of the Verify.. options checked on in Report Options?

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Feb 01, 2017 at 06:30 PM

    Hi,

    Actually, it does not have to be Crystal Reports Viewer. Just plain Preview on the Crystal Report. See below for Report Options. I have the following check on (Database Server is Case-Insensitive, Use Indexes or Server For Speed, Verify on First Refresh, Create Group Tree, Display Alerts on Refresh, Select Distinct Data for Browsing, and Prompt For Hyperlinks).

    report-options.jpg

    Dennis

    Add comment
    10|10000 characters needed characters exceeded