Skip to Content
avatar image
Former Member

PCO Query: tag not found

Hi,

I am writing values to a datablock on a PLC using SAP PCO and OPC as middleware.

It is working for all tags in the datablock except for 2.

This is a screenshot of both tags in the OPC Quick client (I am using Kepware OPC server).

I can read and write the tags from here.

I have created a small test. In the MII workbench I created a PCO Query.

Next I dragged the two tags from the tag browser on the left, to the right.

For both tags I filled in a value.

When I execute the query I get following error messages.

  • M1 Order Dispatch/OrderQuantityTarget: Tag PoederMagazijn/ATS PLC/M1 Order Dispatch/OrderQuantityTarget not found.
  • M1 Order Dispatch/OrderQuantityConfirmed: Tag PoederMagazijn/ATS PLC/M1 Order Dispatch/OrderQuantityConfirmed not found.

Any other tags work fine.

Thank you for your time.

opc.png (2.7 kB)
pco.png (38.6 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Mar 25, 2015 at 05:47 PM

    Hi Philippe,

    Can your provide the following:

    • OPC Server vendor, version
    • Target PLC brand/model
    • PCo version and patch
    • MII version and patch

    Regards, Steve

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      I have been seeing this problem, too.  One day, I can read the tags and the next, they are not found.  Oddly coincidental, but I also had the problem with two tags.  Have since stopped using PCo.

      @Steve,

      MII:  v11.5

      Destination:  OSI PI, via OLEDB

      PCo:  15.0.3.227