Skip to Content
author's profile photo Former Member
Former Member

SAP Web IDE – Error while Deploying Kapsel App to Local Hybrid Application Toolkit(HAT)

Hi All

We are using SAP Web IDE on HANA Cloud to develop custom Fiori application with Camera/Bar-code functionality. We are able to setup the Cloud Connector and HAT toolkit and tested/connections without error. We validated the local environment by executing command "check_env" and there was no error. But we are facing issues when deploying the Kapsel application from HANA Cloud to local Hybrid App tool kit(HAT).

I followed the document: SAP Web IDE Hybrid App Toolkit Add-on.

I've included all screen shots as well.

Testing STEPS: check_env file

I am getting below error message when we try to deploy Kapsel App to local HAT

If you have experienced this issue or if you think that we are missing something, please let me know.

Thank you in advance for your help.

~Ashok.

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

3 Answers

  • Best Answer
    Posted on Mar 26, 2015 at 03:38 AM

    Take note that TODAY Web IDE will be updated to version 1.9.3 and the corresponding Hybrid Application Toolkit version is 1.2.6

    You will notice that we've replaced the check_env script with a GUI based installation assistant, which makes the setup much easier. Hope this helps.

    Thanks,
    Ludo

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Mar 26, 2015 at 03:32 AM

    Hi Palani,

    It seems you are using an older local HAT version than that of the Web IDE HAT plugin. In Web IDE HAT plugin v1.2, we use a different method to transfer the project zip file. You can check the hybrid plugin version via Tools > Preference > Plugins > Available Plugins.

    Please try updating your local HAT to v1.2.

    Regards,

    Zhigao

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Mar 25, 2015 at 12:21 AM

    check https://localhost:9010 in browser

    hope you have given your web ide url in config.json

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.