Skip to Content
Mar 20, 2015 at 08:07 AM

IDM 8.0 Identity Management Database not updated properly



Yesterday I upgraded successfully my SAP IDM 7.2 instance to 8.0.

After configuring SSL for Eclipse I recieve the error message on Login: Identity Management Database not updated properly

Before this message I got the Error message on the idmdevstudio Java Application:

ErrorCode: 0, ErrorMessage: The SELECT permission was denied on the object 'mc_dbschema', database 'mxmc_db', schema 'dbo'.
OpenSQLExceptionCategories: [], CausedBy: 0

I changed the select rights on this table to public (for testcases) and it "worked"

I re-run the mxmc_update.cmd script with no success.

The first time I ran the script all Identity Stores where updated successfully (status code 0).

There is the RDS kit installed from 7.2

It's a Windows Server 2012 with SQL Server 2012, I installed all on the same machine.

I ran the update script with user mxmc_oper and the db connection on netweaver is configured with mxmc_prov.

Any Ideas how to debug?

Or any Ideas how to fix?

Thanks, Patrick