Skip to Content
0
Former Member
Mar 16, 2015 at 09:38 AM

SAPUI5 error "404 not found"

1000 Views

Hi all,

I'm looking into the SHINE content for SAPUI5, Odata, XS etc. Looks very nice, and it's working fine. (HANA dev edition 1.91 via MS Azure!)

The next step I'm trying to take is to make some examples myself. First by starting simple and replicating the shine content into a project of my own.

I started with exposing a table using Odata (.xsodata file), which works fine.

When I run it in the HANA web server, I get the logon screen, and after logging on I get the XML or JSON. Nice.

I also created an .xsjs which returns a json of the same data, also nice. I'm on a roll, or at least that's what I thought...

Now I want to display this data in a SAPUI5 application, which is also in the shine content.

The Shine content works fine. But now I want to redo the shine content in a custom package.

And there it goes wrong.

No matter what I do, I always get error "404 not found" when running the html page in the hana web server.

I don't even get to the login screen. Immediately I get this error.

Let me also add that the shine content (so sap package) works fine. Only if I run the same code in a package created by me, it does not work.

I also copied the (working) shine content into my project. Result: this copied code does not work, the same error.

The generated URL seems to be ok, the code is checked, shared and committed.

What could this be?

I already reinstalled my hana studio and addons + sapui5, but the issue remains. Am I missing something?

XS, UI5 etc seem to work fine, or the shine content wouldn't work.