Skip to Content
avatar image
Former Member

How to develop with SAPUI5 version 1.42 in Eclipse

Hi,

is it possible to use version 1.42.x in Eclipse or only in WebIDE?

Currently im using the sapui5 eclipse plugin which is version 1.40.

I want to use sap.m.tree which is since 1.42.

Thanks,

Martin

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

8 Answers

  • Jan 30, 2017 at 12:35 PM

    just upgrade your ui5 eclipse plugin

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jan 30, 2017 at 01:22 PM

    Hi the latest version for Eclipse is 1.40 on https://tools.hana.ondemand.com/neon/

    I could use the url "https://sapui5.hana.ondemand.com/resources/sap-ui-core.js" as source, but i want to use it offline.

    Add comment
    10|10000 characters needed characters exceeded

  • Jan 30, 2017 at 05:24 PM

    it is 1.42 for me!

    Add comment
    10|10000 characters needed characters exceeded

  • Jan 30, 2017 at 06:41 PM

    just checked one more time. plugin version is 1.40.11. but this is not ui5 version.

    ui5 version is 1.42 in this plugin.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jan 31, 2017 at 02:45 PM

    strange, i have the plugin version 1.40.11 but ui5 version is 1.40.9

    I also checked for plugin updates in Elipse.

    Please see attachements.

    Add comment
    10|10000 characters needed characters exceeded

  • Jan 31, 2017 at 03:38 PM

    run an application in your eclipse, access the app from chrom and type sap.ui.version in the console

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jan 31, 2017 at 04:47 PM

    ok, here i have 1.42.7 but why is there no sap.m.Tree ? And why is resources/sap.ui.core.js on version 1.40.9?

    Add comment
    10|10000 characters needed characters exceeded

  • Jan 31, 2017 at 05:00 PM

    for me it is 1.42.9

    if I type sap.m.Tree in console, I got something, so I believe it is there

    Add comment
    10|10000 characters needed characters exceeded