Skip to Content
0

Parameters prompting two times for Crystal Reports (for Visual Studio) and the message

Jan 30, 2017 at 06:52 AM

46

avatar image

Hi All,

We have 7 Crystal Reports (created in Visual Studio) based on Informix Stored procedures that have parameters defined .No report has subreport.

When we click on 'Main Report Preview',parameters are prompted, after filling the values, clicking ok and then giving the connection information -

1. again parameters are prompted

then again filling the values

2. the message comes "database file [Sproc name] has changed.proceeding to fix up the report." We click ok and report is populated.

What is happening in above two points? I think we do not have updated CR templates that is why the message (in 2nd point ) is appearing.

Thanks and Regards,

Amit

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Best Answer
Abhilash Kumar
Jan 30, 2017 at 07:42 AM
0

Hi Amit,

Open the report in the CR Designer and:

1. Go to the Database Menu > Click 'Verify Database' > You'll be prompted to enter values > Enter them click OK > Save.

This should take care of the 'database has changed' message.

For the prompts issue, please verify if you've created 'dynamic' prompts in the report.

-Abhilash

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Thanks Abhilash for your prompt reply.

The 'message problem' is solved as per your suggestion. However can you please explain why that message appeared at the first place.

As I am working first time in CR , I am googling 'Dynamic prompts in Crystal Reports' meanwhile can you please tell me how to check Dynamic prompts in Crystal Reports.

Thanks and Regards,

Amit

0