Skip to Content
1
Feb 26, 2015 at 04:09 PM

PCo 15 - OPC,SSCE and Websockets

285 Views

I try to connect PCo-Websocket with SSCE-Dashboads, but it doesn't work =(

If I create a Tag with the PCo-Simulator, it all works well.

What I've done:

I read the this guide : http://www.sdn.sap.com/irj/scn/go/portal/prtroot/docs/library/uuid/208cf8a0-70f4-3110-c3ab-dc765ad8474e?QuickLink=index&…

1. Install a Kepware 5.16 Server

2. Create a PCo-Source System for the Kepware-Server with Type OPC-DA

3. Create a Agent

4. Add Subscription-Items (Random1, Random2, Random3, Random4)

5. Configure the Query-Ports like mentioned in the guide.

6. Add a Template-Notification like mentioned in the guide.

7. Start the Agent

8. Create a Data-Server like mentioned in the guide

9. Create a Tag, connect it to the Data-Server, as Tag I use the name of the subscription-elemnt (Random1, etc.)

10. Put the Tag in a SSCE Dashboard in Current-Mode

If I execute the Dashboard than I see errors like that in the PCo log

"Tag null/Random1 with alias tag_A49F469A6D3EE7DE2C9B874B5CDC5EA2D not found."

I doesn't understand where the "null/" comes from?!

____________


What I also tried:

1. Created a Simple Websocket-Client

- I see that PCo is creating a Web-Socket-Server if I start the Agent

- I see that PCo is stopping the Socket-Server if I stop the Agent

2. Create a Websocket-Notification(not a template!) with the same Agent and connect the Simple Websocket-Client

- I see that PCo is creating a Web-Socket-Server if I start the Agent

- I see that PCo is pushing permantly data in to the socket

- I see that PCo is stopping the Socket-Server if I stop the Agent

____________

- It seems that the Kepware-Server works

- It seems that the PCo-Websocket works


____________


I hope anybody has an idea what is going wrong?!