Skip to Content
avatar image
Former Member

Kernel upgrade 7.20 NW 7.02

Hi,

We are looking to upgrade our kernel to last version as 7.20 will not be supported after Q1 2015.

When checking PAM, we can only see 7.21 as supported.

I found this link that explain the minimum kernel version of 7.4 depending on SP Stack level.

Understanding Kernel Releases for the SAP NetWeaver AS ABAP

What I cant understand or find is why we cant use a upper Kernel version with a 7.02 NW?

Do you have some links or explanations to provide?

Regards,

Adel

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    Feb 26, 2015 at 12:48 PM

    Hi Adel

    720/720 EXT initially replaced all the kernel below and including 7.11 . Also 730/7.31

    Please read the SAP Note  below


    1636252 - Installing a 7.20 kernel in SAP Web AS 7.00/7.01/7.10/7.11


    721/ 721 EXT will replace 720/720  Ext mid 2015


    1713986 - Installation of kernel 721 (EXT)


    It is better of upgrading to 721/721 ext


    1975687 - SAP Kernel 7.21 (EXT) replaces SAP Kernel 7.20 (EXT) as standard kernel in Q1/2015


    Thanks ,

    Manu


    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hello Abdel,

      The SAP kernel is dependent on SAPKB and SAPABA patches (in your SPAM), which is why certain kernels work with certain versions of SAP.

      SAP kernel is nothing but a set of executable files and libraries that run in the OS memory and communicate using inter process communication.

      The ABAP code that is programmed by developers intrinsically call underlying executable in the kernel.

      SAP keeps adding new functionality to new kernel versions that work in sync with relevant standard ABAP or JAVA code, sometimes certain new functionality added at kernel level requires previous functionality to be de-supported or replaced.

      For example if you replaced a C function call with a new function call that requires new set of parameters, the old ABAP code will not be able to make this function call and hence fail.

      For example, you cannot use SAP Kernel 7.20 for SAP R/3 4.6C, you will need a SAP Kernel 6.40 EXT or a downward compatible kernel.

      SAP Netweaver Stack 7.4 has abap/java code that requires Kernel 7.40/7.41/7.42 , however you cannot use SAP Kernel 7.40/7.41/7.42 with lower version of SAP Netweaver 7.0X since the corresponding SAPKB and SAPABA patches will not be compatible.


      More explanation about the SAP Kernel deployment strategy is available in this whitepaper.



      Hope this helps.


      Regards,

      Siddhesh

  • avatar image
    Former Member
    Feb 26, 2015 at 02:19 PM

    Thanks Siddhesh for very details explanations. I understand that new NW version will contains improvement that wont work on below release. But I was expecting for the kernel (not abap code) to work on both.

    I was hesitating on who mark as best answer and the key words were "downward compatible kernel".

    I hope you wont be angry at me but I have marked Manu as best answer.

    Many times I saw this expression in SAP notes but only now understand the complete meaning.

    Many thanks all for your time.

    Regards,

    Adel

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hello Siddhesh,

      I think it is important to reward people accordingly.

      When I started there were no scn as well and we had sapfans 😊

      But SAP comes with so many new products and improvements that sometimes it is easy to be aware on the surface only.

      Have a great day too.

      Regards,

      Adel