Skip to Content
avatar image
Former Member

TRs possible if tp versions is different

Dear Experts,

R3trans perform import-export of Transport requests independent of R3trans versions.  Means,transport possible if DEV and QAS has different version of R3trans.

As we know tp calls r3trans for doing Transports. Does same is applicable for tp version ?

Please tell me.

Regards

S. Basis

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • Best Answer
    avatar image
    Former Member
    Feb 25, 2015 at 04:51 AM

    Hi S Basis,

    Unless an untill your not using unicode or non-unicode kernel and version differences. there wont be any issue with transports.

    Like you can not use unicode tp & non unicode R3trans or vice versa.

    In same landscape of unicode kerenel, even if the tp or R3trans version are different it will not impact the transports. unless those are SP packs of SAP. As in new Support packages there might be some corrections which requires latest tp or R3trans versions. For normal SAP development objects the different tp or R3trans versions should not impact.

    Note:- SAP says to maintain the equivalence levels of versions in all exes.

    Regards,

    Ram

    Add comment
    10|10000 characters needed characters exceeded

  • Feb 25, 2015 at 05:01 AM

    Hi

    Yes, you can do the transport. but you have to keep the same kernel release and level with the landscape as soon as possible.

    BR

    SS

    Add comment
    10|10000 characters needed characters exceeded

  • Feb 25, 2015 at 10:52 AM

    Hi Sbasis ,

    I  had  seen issues with doing this  . QA and PREPROD was in different R3trans and tp versions .

    When transports went to Preprod it failed with return code 8  ( IT had all went with return cod 0 in  QA ) as preprod had the latest patch and additional checks where done by this R3trans/tp .

    It was not spotted easily  as the difference in the tp/R3trans were not known .

    At least you know that the versions are different , why do you want to do this .

    It may not cause any issues in your case   but it is not recommended

    Thanks ,

    Manu

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Feb 25, 2015 at 05:41 AM

    Hi ,

    Yes ,it is possible to  higher level versions (R3trans)  only possible to transport the request dev to qlty . Lower than versions you can't  move the request.

    When the reqst trying to export /import  you can select the OPTIONS -> Ingnore invalid component version tick on that and move the request.

    Thanks,

    SRamesh

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Sbasis,

      Yup you can use different version of R3trans/tp for same type(unicode/non-unicode) kernels.

      But recommendation keep patch levels same.

      Regards,

      Ram