Skip to Content
avatar image
Former Member

Diagnostic agent not connecting to solman (Java.lang.ThreadDeath in com.sap.engine.services.rmi_p4.P4ObjectBrokerClientImpl.close())

Hi Experts,

I am trying to connect diagnostic agent to solman.

I run the command

./smdsetup.sh managingconf hostname:'sap.psamer.ps.is.com' port:'8040' user:'SMD_AGT' pwd:'pass'

i waited for 1 days but didnt connected

in the logs i Found

Warning Thread.stop() called using java.lang.ThreadDeath in com.sap.engine.services.rmi_p4.P4ObjectBrokerClientImpl.close()

User Id is correct  password is also correct and i gave sap all authorization to SMD_AGT User .

Earlier agent was connect .

Dont know what happed to in last few days .

Please help

Thanks

Pramod

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • Best Answer
    avatar image
    Former Member
    Feb 23, 2015 at 06:58 AM

    Hi,

    Can you check your P4 port. It should be http port number + 4.

    Regards

    Rishav

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Feb 23, 2015 at 06:48 AM

    Hi Pramod,

    I've refered the below scn link for a similar issue that I had earlier

    http://scn.sap.com/thread/3448611

    Regards,

    Nikhil

    Add comment
    10|10000 characters needed characters exceeded

  • Feb 24, 2015 at 11:07 AM

    Hello ,

    Also can u try through SLD

    # Registration of agent on sld

    smdsetup sldconf hostname:"servername" port:"5xxxx" user:"j2ee_admin" pwd:"xxxx"


    Regards,

    Manoj

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Feb 24, 2015 at 01:23 PM

    Hi Guys,

    These are the steps I perform as suggested by you all .

    1. I go to path /usr/sap/D73/SMDA73/script  and I executed the command

              ./smdsetup.sh managingconf hostname:'sapr3001.psamer.ps.ge.com' port:'8040' user:'SMD_AGT' pwd:'xxxxxx'     here sapr300... is my solman host name 40 is instance number

         2. SMD AGENT is already registerd in solman . i check in sld administration -->           componenent  information

        3. I checked the P4 port by url hostname:8140/msgserver/text/logon  . i found that p4 port is not there

         4. I restarted solman and i executed the same URL then p4 port appeared again

         5. then i againg executed the command ./smdsetup.sh managingconf hostname:'sapr3001.psamer.ps.ge.com' port:'8040' user:'SMD_AGT' pwd:'xxxxxx

    and i checked after some time Diagnostic agent got connect to solman

         I figured out that P4 port is the problem .

    Guys does any one has idea why P4 port got disappreared  and after restart it came up .

    and is there any way we can register P4 port .

    Thanks

    Pramod

    Add comment
    10|10000 characters needed characters exceeded