Skip to Content
0
Former Member
Feb 17, 2015 at 01:32 PM

Can't start database in read only mode

395 Views

I have "borrowed" Breck Carter's concepts for backing up and validating a database that I found on his blog. All seemed to be working well until this morning.

This is SA 12.0.1.3967 running on linux.

The failure is occurring when trying to start the validation database in read only mode. This is after the transaction log has been applied to it.

I would simply get an error "Error: Database cannot be started -- unable to start database...". I'm sorry, but this error is just about useless because it gives no other details.

I tried several times to start it but always go the same error.

I saved off the backup that wouldn't start and re-ran my backup script. That time everything worked just fine.

Anyway, I went back to the backup that wouldn't work and tried to start it again read only and still failed. I then tried to start it normally and it started right up. I then tried to start is read only and it started then too.

Does anyone have any clue as to why it would behave this way?