Skip to Content
avatar image
Former Member

Issue in idocs sent through XML HTTP port

Hi All,

I'm currently working in PI 7.3 dual stack. There is an issue with the CREMAS and MATMAS idocs that are sent from ECC systems. They are being sent through XML HTTP port to PI.

When reaching PI, failing in moni with error "No receiver could be determined". I have checked the message header and the receiver determination, no issues with that.

 

But when I post the same messages from PI integration engine in RWB, they are getting processed successfully and sent to the corresponding receiver system. So what is the actual problem here? I'm not able to locate the issue. Please help.

Thanks,

Jegatha

Capture1.PNG (26.6 kB)
Capture2.PNG (6.2 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

8 Answers

  • Best Answer
    avatar image
    Former Member
    Feb 25, 2015 at 01:14 PM

    Hello All,

    Thanks for all your inputs!!

    Finally, the issue is solved. The mistake was in the HTTP path used, where there was a unwanted space between '=' and the BS name. We removed it and it started working.

    Thanks,

    Jegatha

    Add comment
    10|10000 characters needed characters exceeded

  • Feb 20, 2015 at 10:16 AM

    Hi,

    Try clearing sxi_cache.

    Regards,

    Mark

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Azhar Shaikh

      Hi Shaikh,

      Thanks for the document. I have configured all the steps as mentioned. The issue has ben resolved as there was some mistake in the HTTP path used in ECC!!

      And in the document, it was said like to use HTTP plain adapter in the sender side, which we are not using, but the interface works.

      Thanks,

      Jegatha

  • avatar image
    Former Member
    Feb 17, 2015 at 10:11 AM

    Hi,

    Please give a screen shot of the failed and successful message in Moni along with your Interface determination and Receiver detrmn

    Regards

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Feb 17, 2015 at 10:56 AM

    Hi Praveen and Sriram,

    Yes. They are matching exactly. Below are the failed message and the same message which has been sent rwb has been processed successfully.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Feb 17, 2015 at 11:48 AM

    Seems like a configuration issue. Was this working before or is a new interface?

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      This interface is not working since it has been created. I have re-configured all the objects and checked. But still no luck.

      Below are the configurations in place. Tell me if anything else I should check.

      HTTP connection (RFC destination type H)from ECC pointing to PI. (necessary partner profile and XML HTTP port)

      RFC destination type 3 pointing to ECC system in PI.

      Thanks,

      Jegatha

  • avatar image
    Former Member
    Feb 17, 2015 at 12:06 PM

    Check sender service and sender interface as displayed in SXI_MONITOR and compare names to those, which receiver determination is configured for. Are they for sure the same?Also message & its namespace, does it fullfil the interface description?

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Sriram,

      We have tow interfaces for CREMAS and MATMAS. CREMAS is sent to one receiver and MATMAS is sent to two receivers where we have used Rx condition to determine the receiver. But the problem is in both the interfaces.

      I checked by testing the configuration with the same payload in ID. It works fine.

      Thanks,

      Jegatha.

  • avatar image
    Former Member
    Feb 18, 2015 at 02:43 PM

    Hi Jegatha,

    Please provide a screen shot of the RD(complete) for both CREMAS and MATMAS and also the the configuration test in ID successsful one

    Regards,

    Sriram

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Feb 20, 2015 at 09:34 AM

    HI Jegatha,

    Thanks for the screen shots. It looks fine. Can u try dummy activating the receiver determination and receiver agreement and try restarting the msg

    Regards,

    Sriram

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Sriram,

      I did some dummy change and activated. I tried restarting from sxmb_moni, but failed to process. I have posted the same message from RWB, then it got processed!!

      Regards,

      Jegatha