Skip to Content
Former Member
Feb 16, 2015 at 05:28 PM

Custom field on FPM form always read-only



I want to enhance a component configuration (form UIBB) by adding a new input field. This configuration has assigned an FBI View so it also has a business object. The problem is that the new field is always read-only. I've tried all the things from in this forum for this topic– to modify in get_data and get_definition from feeder class but nothing is working, I think somewhere these attributes are overwritten, because I've tried to make another field that was on the screen mandatory and didn't work.

I've discovered that it’s working for fields with a search help assigned, but for my particular field it’s still not working.

In order to add the field on the screen I enhanced the Node UI structure . And If I check in BOPF object in Node Category in the tab Attribute Properties the read-only property is checked for my field. I think because of this reason that field is always read-only. Do you know if I can change it? Can I enhance somehow the BOPF in order to change that tick in the Attributes Properties ?

Or do you have another idea for how to solve this problem?

Thank you,