$(function () { pageContext.i18n.modTalk = 'moderation talk'; pageContext.i18n.replyToComment = 'Reply'; pageContext.i18n.modTalkEmpty = 'moderation talk is empty'; pageContext.url.getModTalk = "/comments/%25ID%25/listModTalk.json"; pageContext.url.possibleCommentRecipients = "/comments/%ID%/possibleRecipients.json"; pageContext.url.commentEdit = '/comments/%25ID%25/edit.html'; pageContext.url.commentView = '/comments/%ID%/view.html'; pageContext.i18n.commentVisibility = { 'full': 'Viewable by all users', 'op': 'Viewable by the original poster', 'mod': 'Viewable by moderators', 'opAndMod': 'Viewable by moderators and the original poster', 'other': 'Advanced visibility', 'dialogTitle': 'Comment visibility', 'selectGroups': 'Visible to groups', 'selectOther': 'Other recipients', 'selectOriginalPoster': 'Original poster', 'selectModerators': 'Moderators', 'selectAssignees': 'Asked to answer users' }; pageContext.i18n.commentMenuLabels = { 'comment-edit': 'comments.menu.edit', 'comment-delete': 'comments.menu.delete', 'comment-convert': 'comments.menu.convert' };pageContext.i18n.answer= { bestAnswer: 'Best Answer', controlBar : { accept: 'Accept', unaccept: 'Unaccept', acceptCommand: 'Accept this answer as correct', cancelAcceptedCommand: 'Remove this answers accepted status' } }; window.croles = { u: false, op: false, m: false, og: false, as: false, ag: false, dc: false, doc: false, eo: false, ea: false }; tools.init({ q: { e: false, ew: false, eo: false, r: false, ro: false, d: false, dow: false, fv: false, c: false, co: false, p: false, tm: false , ms: false, mos: false }, n: { f: false, vf: false, vfo: false, vr: true, vro: true, c: false, co: false, vu: false, vd: false, w: false, wo: false, l: false }, c: { e: false, eo: false, d: false, dow: false, ta: false, tao: false, l: false }, a: { e: false, ew: false, eo: false, d: false, dow: false, a: false, aoq: false, ao: false, tc: false, tco: false, p: false, tm: false }, pc: croles }, { tc: true, nsc: true }); commandUtils.initializeLabels(); }); Skip to Content

Database Studio >= 7.9.08.27 not working on Windows 32 bit

Eclipse starts normally and shows the workspace (without MaxDB specific items) but there is an error message "Wrong Java VM 32/64-Bit-Version. Current Java VM: 'Java HotSpot(TM) Client VM' 32 Bit. Required Java VM must fit os x86 bit."

JVM and DbStudio are 32 bit (tried Oracle 1.7 and 1.8).

This seems to be a side effect of PTS 1252979.

I also tried a 32 bit SAPJVM 6.1 (-vm parameter in dbstudio.ini). Same error message with "Current Java VM: 'SAP Java Server VM' 32 Bit".

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    Feb 20, 2015 at 09:05 AM

    Hello Sebastian,

    we have fixed this with Database Studio 7.9.08.29 32 bit (Windows)

    Here is a preliminary version for download (should not differ from the final version):

    https://mdocs.sap.com/mcm/public/v1/open?shr=lKbtdHzNF8RVuAPx9w5h1tIrHFS5BuURUNz67_VXkIY


    Please let me know, if it works for you.

    Regards,
    Thorsten

    Add comment
    10|10000 characters needed characters exceeded

  • Feb 17, 2015 at 01:56 PM

    Thank you for this information.

    We will correct this in one of the next patches.

    Best regards


    Add comment
    10|10000 characters needed characters exceeded