Skip to Content
author's profile photo
Former Member

Design Studio 1.4 cannot execute on SAP Netweaver Portal Parameter object with the name "URL_PARAM" and the index "0" still does not exist

Hi experts

if i execute my Design Studio 1.4 application on the Netweaver Portal 7.3 out from Design Studio, i receive the following Error:

Analysis Application
Parameter object with the name "URL_PARAM" and the index "0" still does not exist in the parameter l [...] While processing the current request, an exception occurred which could not be handled by the application or the framework.

Log ID: C0000A8935C0023D0000001F009F0020 Unable to process request. Contact your system administrator.
To facilitate analysis of the problem, keep a copy of this error page We are sorry for the inconvenience Copyright © SAP AG. All Rights Reserved. Parameter object with the name "URL_PARAM" and the index "0" still does not exist in the parameter list: Analysis Application Unable to process request. Contact your system administrator. Information for Administrator Error Summary
While processing the current request, an exception occurred which could not be handled by the application or the framework.
If the information on this page does not help you locate and correct the cause of the problem, contact your system administrator
To facilitate analysis of the problem, keep a copy of this error page Hint: Most Web browsers allow you to select all content, and copy and paste it into an empty document (such as in an email or simple text file)

Details Root Cause The initial exception that caused the request to fail was: Parameter object with the name "URL_PARAM" and the index "0" still does not exist in the parameter list: < parameterList>< param name="NAME" value="g_toolbar_mode"/>< param name="VALUE" value="''"/>< /parameterList> com.sap.ip.bi.base.exception.BIBaseRuntimeException: Parameter object with the name "URL_PARAM" and the index "0" still does not exist in the parameter list: < parameterList>< param name="NAME" value="g_toolbar_mode"/>< param name="VALUE" value="''"/>< /parameterList> at com.sap.ip.bi.base.parameter.impl.ParameterList.getParameterWithUpperCaseName(ParameterList.java:735) [...] Thank you for your help to solve it! Kind regards, Adrian
Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

3 Answers

  • Best Answer
    Feb 11, 2015 at 06:20 PM

    Hi,

    you have to synchronize versions in CLIENT and NW deployment. This issue occurs when you save the application with release 1.4 and on NW you have still deployment of release 1.3.

    For those who want to know why - DS 1.4 is reducing the size of the application XML (BIAPP file) and removing all properties which are equal to the default values). 1.3 is not recognizing then such applications, in this case, the property "URL_PARAM" is not changed and therefore not in the app definition.

    Simply, deployment of the SCA in release 1.4 on your portal server will help here.

    Karol

    Add comment
    10|10000 characters needed characters exceeded

    • Adrian,

      the initial exception:

      Parameter object with the name "URL_PARAM" and the index "0" still does not exist in the parameter list: < parameterList>< param name="NAME" value="g_toolbar_mode"/>< param name="VALUE" value="''"/>< /parameterList>

      com.sap.ip.bi.base.exception.BIBaseRuntimeException: Parameter object with the name "URL_PARAM" and the index "0" still does not exist in the parameter list: < parameterList>< param name="NAME" value="g_toolbar_mode"/>< param name="VALUE" value="''"/>< /parameterList> at com.sap.ip.bi.base.parameter.impl.ParameterList.getParameterWithUpperCaseName(ParameterList.java:735)

      was caused by execution of an application saved with 1.4 on system with deployment of 1.3.

      The other issue with connectivity is not related to the release (at least should not be). This is configuration issue, check the log file on the Java stack, you will see what is wrong.

      Karol

  • Feb 11, 2015 at 12:49 PM

    Adrian - would you please follow the troubleshooting steps listed here? http://service.sap.com/sap/support/notes/1894594

    Although it may not apply this note http://service.sap.com/sap/support/notes/2077647 has a nice how-to on how to set up an iView for Design Studio

    Also please check page 24 of the PAM https://websmp110.sap-ag.de/~sapidb/012002523100018972812014E - are you on the right SP for NW/Portal 73 that supports the NetWeaver add-on?

    Add comment
    10|10000 characters needed characters exceeded

  • author's profile photo
    Former Member
    Feb 11, 2015 at 01:02 PM

    Hello,

    we are experiencing exactly the same error. We upgraded from DS 1.3 to 1.4 SP0 Patch 2. Applications run as "Execute locally" are working fine. Applications saved with Version 1.4 produce the same error as above when opening them via BI Launch Pad.

    Our basis team is investigating the error and we already send a support message to SAP. Let`s stay in touch - hopefully we can solve this problem.

    Regards

    Jan

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hello Jan, yes if we found a solution, will let you know. Meaning is to import new .SCA to NW Portal, but we have to test. Let you know about results.

      Regards,

      Adrian