Skip to Content
0
Jan 10, 2006 at 09:13 AM

SSL_ERROR_CONNECTION_LOST

1576 Views

Hallo everybody,

now I have problem in XI with RFC connection to the external server by SSL to the https:// site.

When I try the connection by "Test Connection" Buton in SM59, then I get error message ICM_HTTP_SSL_ERROR. When I looking to the trace file (SMICM) there are this records:

NiSetStat: state hdl 31 NI_CONNECTED

IcmConnInitClientSSL: initiate proxy-connect with https://xxx.xxxxxxx.com:xxxx

IcmConnProxyHandshake: send proxy-authorization header for user: xxxxxx\xxxxxxx

NiIWrite: write 146, 1 packs, RAW_IO, hdl 31, data complete

NiIPeek: peek successful for hdl 31 / socket 31 (r)

NiIRead: read 105 RAW_IO, hdl 31

data (105) from proxy:

HTTP/1.0 200 OK#

pe: text/html#

; URL=https://xxx.xxxxxx.com:xxxx#

ML>#

<<- SapSSLSessionInit()==SAP_O_K

in: args = "role=1 (CLIENT), auth_type=3 (USE_CLIENT_CERT)"

out: sssl_hdl = 0x115a3b7b0

NiHdlSetBlockmode: set blockmode hdl 31 TRUE

SSL socket: local=xx.xxx.xx.xx:xxxxx peer=xx.xxx.xx.xx:xxxx

<<- SapSSLSetNiHdl(sssl_hdl=0x115a3b7b0, ni_hdl=31)==SAP_O_K

SapISSLComposeFilename(): Filename = "/usr/sap/xx/xxxxxxxx/xxx/xxxxxx.pse"

WARNING: xxxxxxx.pse missing using yyyyyyy.pse as fallback

<<- SapSSLSetSessionCredential(sssl_hdl=0x115a3b7b0)==SAP_O_K

in: cred_name = "/usr/sap/xxx/xxxxxx/xxx/xxxxx.pse"

<<- SapSSLSetTargetHostname(sssl_hdl=0x115a3b7b0)==SAP_O_K

in: hostname = "https://xxx.xxxxxx.com"

<b>*** ERROR during SecudeSSL_SessionStart() from SSL_connect()==SSL_ERROR_CONNECTION_LOST</b>

session uses PSE file "/usr/sap/xxx/xxxxxx/xxx/xxxxx.pse"

No Secude Error present in trace stack!

SSL_get_state() returned 0x00002120 "SSLv3 read server hello A"

No certificate request received from Server

<<- ERROR: SapSSLSessionStart(sssl_hdl=0x115a3b7b0)==SSSLERR_SSL_CONNECT

<<- SapSSLErrorName()==SSSLERR_SSL_CONNECT

<b>*** ERROR => IcmConnInitClientSSL: SapSSLSessionStart failed (-57): SSSLERR_SSL_CONNECT [icxxconn_mt.c 182</b>

<<- SapSSLSessionDone(sssl_hdl=0x115a3b7b0)==SAP_O_K

IcmConnConnect(id=5/123214): free MPI request blocks

MPI<3c300>e#7 GetInbuf -1 2d8f58 246 (1) -> 6

MPI<3c2ff>f#4 GetOutbuf -1 4a95b0 65536 (0) -> 0x7000000704a95d0 0

nihsi-getServNo: servicename 'xxxx' = port 1F.7D/xxxx

MPI<3c2ff>f#5 FlushOutbuf l-1 1 1 4a95b0 2106 6 -> 0x7000000704a95b0 0

NiICloseHandle: shutdown and close hdl 31 / socket 31

IcmConnFreeContext: context 5 released

IcmServDecrRefCount: xxxxxxxx.xxx.xxxxx.xxx:xxxx - serv_ref_count: 1

Setting of RFC:

Connection type:G

Target host: https://xxx.xxxxxx.com

Service No: xxxx

Path Prefix: /xxxxx.asp

Proxy host: xxxx.xxxxx.xxx

Proxy service: xxxx

Proxy user: xxxxx

Proxy password:******

Logon/security:

Basic Authentication

SSL: Active SSL Client certificate: Anonym SSL Client

Logon:

User: xxxxx

PSW: ******

Special options:

No Timeout

HTTP 1.1

Inactive

Compressed response: yes

Accept cookies: No

In tr. SMICM -> Goto -> Services: There is HTTPS active.

Can you somebody help me to diagnose where is a problem?

Thank you very much for your help.

Best regards

Capek Martin