Skip to Content
author's profile photo Former Member
Former Member

Content Server 6.50 Cache Server Test URL returns blank page

Hi,

I am migrating from 32-bit 6.40 Content Server on MaxDB 7.5.00.51 (source) to 64-bit 6.50 Content Server on MaxDB 7.9.08.23. (target) using MaxDB Database Studio 7.9.08.27 to create backups on the source server and execute recoveries on the target server.

SAP Hostagent SAPHOSTAGENT203_203-20005735.SAR has been installed. SAP Note 2028088 for IIS roles has been installed. SAP Note 684106 has been applied (r3dllinst and vcredist) and MSVCR71.DLL has been applied. Ports 1090 and 1095 are open on the internal network for this server and the local system firewall has been disabled on the target server.

When I call the test url for the newly installed content server I receive the following:

serverType="SAP HTTP Content Server";serverVendorId="Copyright SAP AG, All rights reserved 1998, 2001";serverPatch="0";serverStatus="running";serverStatusDescription="";serverDate="2015-02-10";serverTime="16:07:14";startUpDate="2015-02-10";startUpTime="10:58:13";lastAccessDate="2015-02-10";lastAccessTime="16:04:28";

However, when I call the test url for the cache server, I receive a blank page.

When I test the connection in IIS server (Sites: SAP Cache Server: Basic Settings: Test Settings) I receive and authorization error: Cannot verify access to path (C:\Program Files\SAP\CacheServer). Details are:

"The server is configured to use pass-through authentication with a built-in account to access the specified

physical path. However, IIS Manager cannot verify whether the built-in account has access. Make sure that the

application pool identity has Read access to the physical path. If this server is joined to a domain, and the

application pool identity is NetworkService or LocalSystem, verify that <domain>\<computer_name>$ has Read access

to the physical path. Then test these settings again."

The permissions for the files and directories in the path are the same as for the Content Server dll.

Please advise as to whether this is an issue, or can be ignored

Cache server backup has been successfully restored. I am waiting on file transfer for the Content Server SDB restore.

Many thanks in advance for any information.

PS. Just checked the same settings for Content Server in IIS and I think the IIS Authorization error might be a red herring. Doesn't change the issue of getting a blank page in response to calling the Cache Server test url.

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

1 Answer

  • author's profile photo Former Member
    Former Member
    Posted on Aug 13, 2015 at 08:21 AM

    Hello Maria,

    was there a solution for you problem?

    Kind regards

    Roland

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hello Maria,

      Can you please check the contents of the CSPRoxyCache.ini file present in your cache server installation directory.

      If it as the below entry

      driver = LiveCache

      Change the same via CSADMIN:

      1) Execute the TA: CSADMIN

      2) Specify your cache server and the port
      number and click the change button.

      3) Click the settings tab and specify the
      'driver' parameter value as 'SAP MaxDB SDB' as per the note 1619726

      4)Save the settings

      Restart the IIS and check the serverInfo.

      If the issue still persists then please enable the logs as per the below steps,

      Follow the steps below if you would like to
      know how to enable the traces for cache server.

      1) Execute the TA: CSADMIN

      2) Specify your cache server and the port
      number and click the change button.

      3) Click the settings tab and specify the
      'FullTrace' parameter value as '1'.

      4) Save the settings. Restart the cache
      server.

      You can do this in the Internet Information
      Services.

      This will activate the trace and you can find
      the trace file csproxytrace.txt in the folder (say C:\Program Files\SAP\Cache
      Server) where you have installed the cache server.

      Best Regards,

      Sneha

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.