Skip to Content
Feb 05, 2015 at 04:34 AM

Smart Data Streaming on HANA : Data service discovery not working when running SDS on multiple host



I previously had set up SDS on HANA where streaming-server was running on one node and I was able to run ESP projects on that successfully.

No I want to check how it works when there are multiple node as streaming node. So I did the following :

  1. I have three hosts, let's assume their DNS full names are hana, sds1 and sds2. I installed HANA and SDS in hana system and added sds1 and sds2 as streaming host.
    ./hdblcm - -action=add_hosts - -addhosts=< Smart_Data_Streaming _host_full_DNS>:role=streaming
    Everything works out pretty well and HANA system was up and running with two streaming host.

  2. Next I installed unixODBC driver in sds1 host, as mentioned in the admin and configuration guide of SDS and then created the symbolic link as stated there. Also added the line LD_LIBRARY_PATH="/usr/local/lib":$LD_LIBRARY_PATH export LD_LIBRARY_PATH in the file /hana/shared/<SID>/streaming/ as per the document. After that restarted the HANA system. Also created a datasource in the .odbc.ini file of /usr/sap/<SID>/home as mentioned in the document.
  3. Now I added the streaming host sds1 in the eclipse server view and then created a service using the datasource. When I try to discover schemas from that service, it throws an error(see the attached image).

While setting up the same for one host which I did previously, I followed exactly the same steps and it worked! Is there something that I am missing here ?

Also my intention of setting up multiple streaming server was to create a streaming cluster and see how the load balancing and failover works. I saw in the document that ESP cockpit can be opened in web browser with the link as https://<sds1>/cockpit

It does not work for me. What all needs to be done for this cluster configuration ? I have followed the steps mentioned in the document regarding running the file. Even after that the link does not work for me.




Capture.PNG (7.8 kB)