Skip to Content

Padding at the top in the content area in AFP standards mode framework page

Hi Friends,

We are on Netweaver Portal 7.4 SP10. Until now we were using Ajax framework page and now we switched to AFP standards mode framework page but still using the previously created custom theme. It is working ok except few issues. One issue is a 9 pixel thick grey padding at the top in the content area just below the breadcrumbs and full screen button.

When I inspect the element it is coming because of the padding in PrtlFullPageAppBody{background-color:#EBEFF2;margin:0px 0px 0 0;padding:9px 0px 3px 0px}.prtlFocus{}and its path shows /mycustom_theme/prtl_std/prtl_std_standards.css.

I tried to find the corresponding property in my custom theme in the theme editor but I could not find it. My expectation was it is somewhere in portal body section but could not find it. I also tried to download the custom load and search for prtl_std_standards.css. but I don’t see this fill and also the its parent folder prtl_std.

Anyone had this problem before and has any idea how to fix this? Any help is highly appreciated.

Thanks in advance .

Vijay Goli

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • 5 days ago

    You can set "sapPrtPageContFullPadding" of the Ajax Framework Page to 0px in the Theme Designer. This will kill the useless padding.

    /BR Tobias

    Add comment
    10|10000 characters needed characters exceeded

  • Sep 13, 2017 at 11:26 AM

    Hi Vijay

    Regarding your query, can you provide a screenshot, so that I can get more clarity about the part of framework page you are referring to.

    Also check if its happening across all browser's or is it browser specific.

    Regards

    Santarshi Samanta

    Add comment
    10|10000 characters needed characters exceeded

  • May 17 at 10:55 AM

    Any solution for this? I have the same issue (i think everyone using the NW Portal has it). The content area of any AFP view has a padding coming from ".prtlPrtlFullPageAppBody". This is not a browser specific issue. I have tried overwriting it in the custom css part of the theme editor but with no success.

    Add comment
    10|10000 characters needed characters exceeded

    • Dear Tobias.

      I face the same problem when using custom.css (Theme Editor) in order to modify ".prtlPrtlFullPageAppBody" class.

      Did you find a way to reduce the content area padding?

      Thank you.

      Best regards,
      Nacho