Skip to Content
0
Jan 23, 2015 at 08:23 AM

Unable to launch Design Studio 1.4 from Eclipse anymore

47 Views

Hi guys.

I am developping a component for DS in Eclipse, thus I launch DS from Eclipse in order to test it.

After I closed DS yesterday (opened from Eclipse), everything went as usual and then, when I tried to relaunch it, i got this error :

!MESSAGE Problems occurred when invoking code from plug-in: "org.eclipse.ui.workbench".

!STACK 0

java.lang.NullPointerException

at org.eclipse.equinox.internal.p2.ui.sdk.scheduler.migration.MigrationSupport.getLastMigration(MigrationSupport.java:232)

at org.eclipse.equinox.internal.p2.ui.sdk.scheduler.migration.MigrationSupport.baseChangedSinceLastPresentationOfWizard(MigrationSupport.java:193)

at org.eclipse.equinox.internal.p2.ui.sdk.scheduler.migration.MigrationSupport.performMigration(MigrationSupport.java:71)

at org.eclipse.equinox.internal.p2.ui.sdk.scheduler.AutomaticUpdateScheduler.earlyStartup(AutomaticUpdateScheduler.java:89)

at org.eclipse.ui.internal.EarlyStartupRunnable.runEarlyStartup(EarlyStartupRunnable.java:87)

at org.eclipse.ui.internal.EarlyStartupRunnable.run(EarlyStartupRunnable.java:66)

at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)

at org.eclipse.ui.internal.Workbench$55.run(Workbench.java:2555)

at org.eclipse.core.internal.jobs.Worker.run(Worker.java:53)

!MESSAGE An internal error occurred during: "Workbench early startup".

And now I cannot run DS from Eclipse anymore.

I've tried to uninstall DS, erase Analytics folders from C://Users/..., erase manually registery keys belonging to Design Studio then reinstall Design Studio.

I've also tried to download a new Eclipse, and switch to a brand new workspace.

I've even uninstalled all my JRE then cleaned the registery on my laptop, and then reinstalled it but the error is still triggering.

This is getting really annoying as I can't find a solution (change my laptop maybe 😔), the problem seems to come from DS because I am still able to launch other applications from Eclipse.

Any help would be gladly appreciated 😊.

Br,

Vincent