Skip to Content
0
Former Member
Jan 05, 2006 at 07:22 PM

Backup/restore problem....

48 Views

It is regarding a SAP DB 7.4.

I have installed and new instance of SAP DB and SQL Studio. I am able to connect to my instance MQA via SQL Studio. I have taken a full back up of database. Total number of records in one the table is zero. I started to download the data. It is on AutoLog save mode is ON. After loading 10,000 records I took another full back up. He created two log backups, as part of AutoLog save, while loading data into MQA. Now I have two full backups. One at beginning which has zero records and other which has 10,000 records in one of the table. Now started to load more data and loaded another 2000 record and it created one more log back up file as part of the AutoLog save.

First full backup = zero records

Loaded 10,000 records and it created two log backup files

Took full backup with 10,000 records.

Loaded another 2000 records and created one more log backup file.

Now I want to restore with last full backup. When I do it, it restores it successfully. But When I go to SQL Studio to check the records and they are still at 12,000. I was expecting it to be at 10,000.

Then I did further testing and I deleted all the records in the table and brought it to zero. I went to restore it with full backup taken after 10,000 records. It restored it well but all the records are still zero.

So my full backup is basically empty. I made sure that I was restoring it from good backup. Where could I go wrong? I have tried this few times and still same result.

Please advice.

Your help will be appreciated.

Thank you everybody in advance.

Thank you.

SChau