Skip to Content
author's profile photo Former Member
Former Member

No connection to Integration Builder

Hello experts..

when i'm checking SPROXY in R/3....it is giving error "No connection to Integration Builder "

So i checked http://r/3server/exchangeProfile

but nothing was there in exchange profile....can any one tell me how to get the profile there???

Do we need to maintain the SLDAPICUST in r/3 also??

do we need to maintain SLDAPI,LCR rfc's in R/3 also???

Thnaks..

SP

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

4 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Jan 05, 2006 at 05:45 PM

    Hi sp,

    Have a look at this thread...

    no-connection-to-integration-builder

    Regards

    Anand

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi,

      I had the same problem and I have already solved it.

      You have just to apply the following sap notes :

      1232805 - Saint: Queue calculation for an add-on with CRT´s fail.

      769120 - Support Package for APPINT 200_620

      The first one is to update tha SPAM/SAINT to v 30 and the second one allow you use the pi/xi objects on application system.

      There is another sap note 689847, but you just apply this if the sap notes above described did not work.

      Best regards

      Paulo Correa

  • author's profile photo Former Member
    Former Member
    Posted on Nov 12, 2008 at 06:45 PM

    HERE ARE SOME OPTIONS:

    check your RFC LCRSAPRFC

    check that the user matanained in SLDAPUCUST IS CORRECT and is not blocked in PI

    Test SPROXY

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on May 01, 2012 at 12:32 PM

    Hi Sp,

    You need to create a RFC connection SAP_PROXY_ESR of type G in R3

    Click on the error "No connection to Integration Builder " to get the details of RFC destination fields

    after creating the RFC destination as per details... check sproxy

    that should work

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on May 01, 2012 at 06:49 PM

    Hi SP,

    In your RFC Destination (sm59) check the following:

    Type "T" Destinations:

    • LCRSAPRFC
      • make sure that the program ID is the same with what was registered in your PI system. LCRSAPRFC_PID (PID - PI system ID)
      • check also your gateway options if its linked with your PI-SLD or whichever your SLD is hosted
    • SAPSLDAPI - same as above but here check SAPSLDAPI_PID and gateway options

    Type "G" Destination

    • Make sure you have created a destination SAP_PROXY_ESR and has the following
      • Target Host: PI Hostname
      • Port: PI Port (5<sysno>00)
      • Path prefix: /rep

    One more thing is that make sure your configuration in tcode sxmb_adm >> Integration Engine Configuration, The role of Business System is Application System and you have define a destination http://host:port/sap/xi/engine?type=entry or you can create an RFC destination Type "H" and name it as PI_INTEGRATIONSERVER then place the it on the destination the following

    • Target host: PI Hostname
    • Service No: PI Port
    • Path Prefix: /sap/xi/engine?type=entry

    In your Integration Engine Configuration put dest://PI_INTEGRATIONSERVER instead of http://host:port/sap/xi/engine?type=entry

    Hope it helps..

    Let me know if you're still encountering some issues.

    Cheers,

    R-jay

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.