Skip to Content
avatar image
Former Member

SAP gateway distributed install Start of TP sapxpg failed

Greetings to SAP gurus,

We are having distributed installation, application server should communicate with database via SAP gateway.

Gateway is installed on the database and it is running. However while testing TCP/IP RFC SAPXPG_DBXXX we are getting an error, see screenshot

attached:

While checking work log of the gateway , which located in the /usr/sap/SID/G57/work, getting this at the same time we test RFC:

*** ERROR => GwStartProgram: execvp failed (No such file or directory)

[gwuxrd.c 454]

***LOG S34=> GwStartProgram, execvp failed ( 002 sapxpg) [gwuxrd.c

461]

*************************************************************************

*

* LOCATION SAP-Gateway on host dbXXX sapgw57

* ERROR Start of TP sapxpg failed

*

* TIME Wed Jan 14 10:10:11 2015

* RELEASE 720

* COMPONENT SAP-Gateway

* VERSION 2

* RC 667

* MODULE gwuxrd.c

* LINE 464

* SYSTEM CALL execvp

* COUNTER 5

*

*************************************************************************

We have successfull telnet connection for the gateway port 3357 from app server

and I have already checked /sapmnt/SID/exe/sapxpg is present in the kernel directory.

Please point me where should I look for.

Thank you,

Pavlo Slavnskyi

RFC_error.png (28.3 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

5 Answers

  • Best Answer
    avatar image
    Former Member
    Jan 21, 2015 at 12:44 PM

    Hi everyone, thank you for helping out.

    Issue was resolved by local consultant, who checked configuration and hasn't change anything.

    The only thing he did was killed gateway and run cleanipc for it's instance name after that - works like a charm.

    Again thanks everybody for support your and effort.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jan 14, 2015 at 09:15 PM

    Hi Pavio,

    If you are running on a unix platform, run the following command with the user who owns the gateway.

    >>which sapxpg

    what is the output?

    Also in SM49 tcode, create a test command as below and execute it with target destination as SAPXPG_DBXXX and check the output. Is it showing the utility sapxpg in the output ?

    Thanks

    Amit


    pastedImage_1.png (11.4 kB)
    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Pavlo,

      What is the Hostname you have mentioned in the SAPXPG_DBDEST_<hostname> try to connect with the virtual/physical hostname with ip address.

      Also check whether you have the kernel files share among the distributed environment. Normally /sapmnt/<SID>/exe is shared on both Central & Database hosts or a local copy of the Kernel Files under /sapmnt/SID/exe.

      Do check if you have the exe directory availbale as per the LD_LIBRARY_PATH.

      Do let us know if this help. and whats the outcome of this changes.

      Regards,

      Ram

  • avatar image
    Former Member
    Jan 15, 2015 at 11:24 PM

    Checked the note, we having security properly set:

    reginfo,secinfo:

    #VERSION=2

    P TP=* HOST=*

    #VERSION=2

    P TP=* USER=* USER-HOST=* HOST=*

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Pavlo,

      Is the issue resolved or still there. And one more thing i wanted to check are the gateway systems sapMS services maintained at your central instance host.

      And have you followed the recommendations of amit.

      Let us know the outcome.

      Regards,

      Ram

  • avatar image
    Former Member
    Jan 15, 2015 at 01:13 PM

    Hi Ramkrishna, Amit:

    OS: RedHat Linux 6.5

    Kernel files are shared across app server and db server, we have shared:

    /sapmnt/SID

    /usr/sap/SID

    PATH defined properly, as command "which sapxpg" returnes kernel address:

    /usr/sap/SID/SYS/exe/uc/linuxx86_64/sapxpg

    RFC SAPXPG_DBTEST_ can resolve hostname as when I test RFC from SAP I'm getting error written to the work log of the gateway that located on the DB server, so  communication happens, but sapxpg cannot be started for some mystery reason.

    SM49 test returns, PROGRAM_START_ERROR, see screenshot attached


    SM49.png (26.6 kB)
    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Pavlo,

      Apologies for late reply.

      This means that the application server is not able to execute commands on the database server.

      This could mean, gateway security settings are incorrect . These are my setting for reginfo and secinfo file , you can modify yours and check.

      Here is my reginfo file

      #VERSION=2

      P TP=* HOST=internal ACCESS=internal CANCEL=internal

      P TP=* HOST=localhost,10.* CANCEL=localhost,10.* ACCESS=localhost,10*

      and secinfo

      #VERSION=2

      P TP=* USER=* USER-HOST=internal HOST=internal

      P TP=* USER=* USER-HOST=localhost,10.* HOST=localhost,10.*

      This 10* is our IP address range, you can change it you yours.

      Thanks

      Amit

  • avatar image
    Former Member
    Jan 20, 2015 at 07:04 PM

    Hi Ram,

    Thanks your recommendation I've put full path of sapxpg in to the SAPXPG on SM59 and connection test was successful. Which confuse me totally, as "which sapxpg" command return proper path, which I put in to the SM59 RCF parameter.

    In the /etc/passwd/

    csh is defined for both sidam user

    Regarding Amit's recommendation: security wise we have it wide open.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hello Pavlo,

      can you copy brtools, sapxpg, brbackup, brarchive in sidadm home directory and try rfc.

      And remove full path of sapxpg from sm59

      Regards,

      Rajeev