Skip to Content

Repository did not starte due Java Deployment rule set

Dear all,

I installed a new version of java (1.7.0_67) and could not start Repository or Directory anymore.

I added the URLs of the PI sever in the white list of java panel (Tab security) with URL   http://<host>:51000/rep/  or

http://<host>:51000/

and set security level to middle, but if I would like to start the repository I got an error

that it is blocked due Deployment Rule set and that the JAR File could not be verified.

Any ideas whats going wrong? Perhaps some old configuration of my old java version left?

Regards

Chris

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Best Answer
    Jan 14, 2015 at 04:17 PM

    Hi Christian,

    Have you tried to activate your old java version?

    (Sorry my computer is in spanish but the order must be the same)

    Regards.

    Add comment
    10|10000 characters needed characters exceeded

    • I had only the 1.7.0_67 version installed because I thought v1.7 is full supported, but I found this page and because our patch level is 9 I saw that the support of 1.7. starts with patch level 13 for 7.11.

      Therefore I installed Java 1.6.0_34 now and it works. Thanks for your support.

      regards

      Chris

  • Jan 14, 2015 at 04:34 PM

    Chris,

    Please download the .jnpl file of ESR and ID. Use Chrome or Firefox browser, right click on ESR link and download. Then open the .jnpl with Java 6 using command line.

    More info Link.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 13, 2016 at 08:58 AM

    Hi,

    I have found another solution to this problem.

    Please go to
    C:\Windows\Sun\Java\Deployment

    and delete the DeploymentRuleSet file from this location.

    This should solve the problem.

    Thanks

    Sakthi

    Add comment
    10|10000 characters needed characters exceeded